Results 1 to 6 of 6
  1. #1
    Join Date
    Mar 2004
    Posts
    83

    Unanswered: Using the DB, but...not

    I need to add a new field to one of my tables, but when I try to enter design view it's complaining that a query or form bound to the table is open, or another user has the table open.

    I know that when you try to compact and repair the DB while someone else is in it, it will show you the user and machine name causing the problem. When I did that, it showed me. I've tried rebooting, made sure nothing else was open, deleting the lockfiles (did not work btw, file may be in use error), etc.

    I'm positive Im the only one using it right now, how can I fix this problem?

  2. #2
    Join Date
    Oct 2003
    Location
    London
    Posts
    341
    I also get sometimes get this problem - when I don't shut down properly or Access freezes.

    Generally when this happens to me the MS ACCESS Record-Locking Information file hasn't been deleted previously.

    i just close database and delete the .ldb file and that clears it for me. It should delete automatically but sometimes its generally stuck when I get that message.

  3. #3
    Join Date
    Mar 2004
    Posts
    83
    Whenever I try and clear the .ldb file it says it's it's being used by another process :/

  4. #4
    Join Date
    Sep 2004
    Location
    Tampa, FL
    Posts
    520
    I have a similiar issue at times. i end the proccess in task manager.

    Darasen

  5. #5
    Join Date
    Mar 2004
    Posts
    83
    I have no idea what happened, but I got back from a meeting and the lockfiles were gone

  6. #6
    Join Date
    Feb 2004
    Location
    Indiana, USA
    Posts
    79
    I've gotten this message and resolved it by closing the switchboard.

    Usually happens if I have been poking around the database and then decide to change something.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •