Results 1 to 5 of 5
  1. #1
    Join Date
    Jun 2003
    Location
    cape town, south africa
    Posts
    102

    Unanswered: backup files not released

    hi

    I have had trouble with maintenance plans not deleting expired backups, & this filling the hadrdisk. i have now done an agent job using tsql backup with init/skip, so it just overwrites. problem now is that it fails saying the backup device isnt available (cant delet the file from OS either) - so this was obviously the prob with the maintence plans too - sql/os doesnt seem to be releasing the file after it is completed and a server restart is needed to release it...
    anyone know how to sort this?
    thanks
    des

  2. #2
    Join Date
    Dec 2002
    Posts
    1,245
    I never experienced an issue like this; i tend to use the maintenance plan wizard. It creates a new logical file for each backup. After backups are complete, it will then go back and erase any backups that are outside your defined retention window.

    The only time I have had a problem with this methodology was when the backup failed and the maintenance process (rightly, in my view) skipped over the file purge process.

    Are you writing your backups to local disk, tape or across the network?

    Regards,

    hmscott
    Have you hugged your backup today?

  3. #3
    Join Date
    Dec 2002
    Posts
    1,245
    Oh, also please post the script you are using for the backup process.

    Regards,

    hmscott
    Have you hugged your backup today?

  4. #4
    Join Date
    Jul 2003
    Location
    San Antonio, TX
    Posts
    3,662
    I've run into similar situation when multiple instances of the same job attempted to fire SQLMAINT/xp_sqlmaint. Check Task Manager and make sure to check "Show processes from all users" checkbox.
    "The data in a record depends on the Key to the record, the Whole Key, and
    nothing but the Key, so help me Codd."

  5. #5
    Join Date
    Jun 2003
    Location
    cape town, south africa
    Posts
    102

    disk

    hmscott
    am writing to local disk - if i look in the maint plan log, it just says deleing old files - 0 affected, meanwhile there are plenty that should have been.
    if i try to delete them manually however, one will be unreleased(none after that one get deleted.) script is just
    backup database Xxx to xxx with skip, init
    in a multi step agent job, one step for each db - the job works on all the servers but the one which doesnt release...

    rdjabarov
    will check thta out next time it runs, though taskmgr is showing all processes...

    thanks for tips, :-)

    des

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •