I have just moved an asp.net application using SQL Server 2000 from a Windows XP Pro to a test machine running Windows Server 2003 and IIS 6.

When I attempt to access 2 pages in this application I get this error:
----------------------------------------------------------------------------
Login failed for user DOMAINNAME\COMPUTERNAME$
----------------------------------------------------------------------------
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Data.SqlClient.SqlException: Login failed for user DOMAINNAME\COMPUTERNAME$'.


An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:


[SqlException: Login failed for user 'CWC\MIS-2003$'.]
System.Data.SqlClient.ConnectionPool.GetConnection (Boolean& isInTransaction) +472
System.Data.SqlClient.SqlConnectionPoolManager.Get PooledConnection(SqlConnectionString options, Boolean& isInTransaction) +372
System.Data.SqlClient.SqlConnection.Open() +384
System.Data.Common.DbDataAdapter.QuietOpen(IDbConn ection connection, ConnectionState& originalState) +44
System.Data.Common.DbDataAdapter.FillFromCommand(O bject data, Int32 startRecord, Int32 maxRecords, String srcTable, IDbCommand command, CommandBehavior behavior) +304
System.Data.Common.DbDataAdapter.Fill(DataSet dataSet, Int32 startRecord, Int32 maxRecords, String srcTable, IDbCommand command, CommandBehavior behavior) +77
System.Data.Common.DbDataAdapter.Fill(DataSet dataSet) +38
IntranetSupportAppliation.ComputerList.BindDataGri d() in C:\Inetpub\wwwroot\IntranetSupportAppliation_1\Com puterList.aspx.vb:297
IntranetSupportAppliation.ComputerList.Page_Load(O bject sender, EventArgs e) in C:\Inetpub\wwwroot\IntranetSupportAppliation_1\Com puterList.aspx.vb:284
System.Web.UI.Control.OnLoad(EventArgs e) +67
System.Web.UI.Control.LoadRecursive() +35
System.Web.UI.Page.ProcessRequestMain() +731
----------------------------------------------------------------------------

THe funny thing is that the other pages are working fine, and on the XP Pro box everything works.

I'm really not a SQL Server Guru, my level of experience is fairly minimal.

I have set up the security to permit DOMAINNAME\COMPUTERNAME$ access to the database.
I have set up the security to permit COMPUTERNAME\ASPNET access to the database.

Any ideas of what I'm doing wrong?

Thanks.

Doug Dexter