Results 1 to 5 of 5
  1. #1
    Join Date
    Apr 2004
    Location
    zxczxczxc
    Posts
    52

    Unanswered: setting onbar filesystem backup capacity

    hi,

    I want to take a backup to the filesystem on the hard disk. when i do a back up to the filesystem, its getting filled very early around 800MB or so,but my database size is around 10GB. How can i set the volume capacity using onbar.
    Please help me if any has an idea. I have to do it very urgently.



    Bye.
    zxczxczc

  2. #2
    Join Date
    Aug 2004
    Posts
    99
    Hi,

    I also do backups to file system using onbar and ISM (informix storage manager), you dont have to specify to onbar any kind of volume, your file system has to have enough space for onbar to backup your complete database. Are you gettin any error messages ?

    Luis Torres

  3. #3
    Join Date
    Apr 2004
    Location
    zxczxczxc
    Posts
    52

    setting onbar filesystem capacity

    Hi,
    I have a volume ISMData and ISMData Pool mounted on /dbload/informix/data. When the backup was going on, i saw thru ism_watch, onbar was waiting to mount another volume on pool ISMData. so i thought i should specify some capacity for that volume.

    I dont know what would be the problem. There was no error as such. And also when i do ism_show -volumes it shows that the volume is 100% full and
    the size of the volume ISMData was 655MB.



    bye.
    zxczxczc

  4. #4
    Join Date
    Aug 2004
    Posts
    99
    Hi,

    After your backup is complete it will show on the volumes (ism_show -volumes) that they are 100% full, it means that they are 100% full of your backup, not that there is no more space on disk.

    What ism_watch is trying to tell you when its asking to mount another volume is the need for a tape device to create the bootstrap. To solve this problem go into $INFORMIXDIR/etc and edit the onbar file (which is a normal shell), search for the line that contains:

    ${INFORMIXDIR}/bin/ism_catalog -create_bootstrap -pool ISMData > /dev/null 2>&1

    and substitute the ISMData pool to ISMDiskData

    ${INFORMIXDIR}/bin/ism_catalog -create_bootstrap -pool ISMDiskData > /dev/null 2>&1

    its onbars default to save the bootsrap to the ISMData pool, you just have to tell it otherwise. That should solve your problem and the process will not wait anymore for you to mount any more volumes.

    Hope this helps

    Luis Torres

  5. #5
    Join Date
    Apr 2004
    Location
    zxczxczxc
    Posts
    52

    setting onbar filesystem capacity

    Thanks a lot.


    Bye.
    zxczxczc

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •