Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2004

    Question Unanswered: Password protection suddenly on all my DBs! HELP!

    I work with several databases daily on my home desktop computer. This morning, when I tried to open one, a "LOGON" box popped up. When I cancel it, it says "Operation Cancelled by User". I do not have a password because, I never set any securities.

    • ALL of my databases now have this logon box.
    • I am running WinXP/Access2000 on desktop, and Win2000/Access2000 on laptop
    • I have repaired/uninstalled/reinstalled MS Access twice on desktop and no change.
    • If I transfer the dbs by disk to my laptop, they work fine.
    • I have tried to copy and paste the dbs locally, still no change.

    How did all of my databases suddenly become password protected?
    Can I unlock them?
    Why are they protected on one machine and not the other?
    Did XP do this?

    Thank you for your time to help!
    ~Amanda Hefner - Austin, TX

  2. #2
    Join Date
    Nov 2003
    Sussex, England
    I've had this before, when I opened one database that was password protected. Try typing admin as the user name, with no password. That might get you into the database.

    I can't remember how I got out of this loop (it was some years ago) but I think I simply created a new blank database, with no security. That became the default for the rest and none of them needed the dialogue box after that.

  3. #3
    Join Date
    Oct 2004
    Thanks. I tried admin, Admin, etc. & w/o a password (b/c I never have ever set one) and none work. Anything I try to do in Access gives me the logon box.

    If I open Access and drop any menu, select any feature, still I get this logon box, even without a db open at all!

    If I go to >File >New >Create, then I get the box again. I can't even open a new blank db.

    If I open Access, go to >Tools >Convert or Repair >choose a db, then I get the box.

    That's why I thought it was actually the program, rather than the db that is protected, but I can't find anything on password protecting the whole application.

    The whole application seems protected. Yet, I have run password and user ID recovery tools on all these databases, and it returns that they are not password protected. !!!Argh!!!

    ~Thanks for trying.

  4. #4
    Join Date
    Dec 2003
    Dallas, TX
    Hi Amanda and Welcome to the Forum

    Must say I have no real idea to what happened here. Any chance you contracted some sort of virus? Did you download a database file from somewhere else onto your desktop? Seems the problem is on your desktop since you can copy it to disk onto your laptop and it works properly. Once I opened a db file that I d/l from a forum and however that person had A2K setup on theirs affected mine as well.
    When all else fails FIRST, I think WinXP has a feature that allows you to back peddle your system to a date when it worked well. I now think it's called SystemRestore. Might be in either ControlPanel or in Start/Programs/Accessories/SystemTools/SystemInformation. Or go to Start/Find/Files or Folders and then type in SystemRestore. Find that option and go back to a clean registry entry. In Win98 SE I go to Start, ShutDown, Restart in DOS-mode. Then at the C:\ this would be typed "scanreg.exe" without the quotes. Then you have a choice of 3 dates to go backwards into your system registry.
    Also, I would run some sort of AntiVirus software to make sure you don't have a virus in your system. If you don't have one, you can run one online at Works well and it's free. Other than that I have no idea as to how to eliminate your problem. Hope you get it taken care of soon.

    have a nice one,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts