Results 1 to 3 of 3
  1. #1
    Join Date
    Oct 2004
    Posts
    3

    Exclamation Unanswered: Problem with Restart Databas (SQL1015N)

    Hi,

    I have a problem on a Server. It is running a DB2 v7 on Win2K.

    the power went down, and now when i try to connect, i get SQL1015N Error.
    So I try to restart database, and then I Get SQL1015N again, or SQL1042C.


    <Edit>
    I just found the first error record in db2diag.log :

    2004-10-24-00.30.29.401000 InstanceB2 Node:000
    PID:888(db2syscs.exe) TID:932 Appid:none
    data_protection sqlpflog Probe:50

    Being asked to force logs past the current tail lsn
    Dump File:C:\PROGRA~1\SQLLIB\DB2\888932.000 DataQLP_LSN
    Dump File:C:\PROGRA~1\SQLLIB\DB2\888932.000 DataQLP_LSN
    Dump File:C:\PROGRA~1\SQLLIB\DB2\888932.000 DataQLP_DBCB

    2004-10-24-00.30.29.531000 InstanceB2 Node:000
    PID:888(db2syscs.exe) TID:932 Appid:none
    data_protection sqlpflog Probe:50

    Error -2787, reqlsn F50EFC7A7813

    2004-10-24-00.30.29.561000 InstanceB2 Node:000
    PID:888(db2syscs.exe) TID:932 Appid:none
    buffer_pool_services sqlbservEntryPoint Probe:608
    DIA3826C Erreur fatale dans les fonctions de protection des données.

    ZRC=0xFFFFF51D

    2004-10-24-00.30.29.611000 InstanceB2 Node:000
    PID:888(db2syscs.exe) TID:932 Appid:none
    base_sys_utilities sqle_panic Probe:10

    sqle_panic: Panic/sleep = 0000 0000 ....


    2004-10-25-09.18.17.789000 InstanceB2 Node:000
    PID:880(db2syscs.exe) TID:1140 Appid:AC110A26.D00C.041025071811
    base_sys_utilities sqledint Probe:0 Database:GMSSWING
    </edit>


    Attached is the DB2Diag.log...

    Can someone tell me how i can get out of this ?

    thanks Alain.
    Attached Files Attached Files
    Last edited by abour; 10-25-04 at 08:03. Reason: Added Log info

  2. #2
    Join Date
    Jan 2002
    Posts
    165
    Try this:
    First check disks where Your logs exist.If this not help try to restore Your db to end of logs.

  3. #3
    Join Date
    Oct 2004
    Posts
    3
    Quote Originally Posted by zkajfez
    Try this:
    First check disks where Your logs exist.If this not help try to restore Your db to end of logs.
    Thks for the answer,

    The files seem OK, but the date of the 3 log files is the time the error occurred ...

    There is no Backup of the DB (the customer hasn't activated it...)

    Do you see anything else I can do ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •