Results 1 to 5 of 5
  1. #1
    Join Date
    Oct 2004
    Posts
    2

    Unanswered: subreport parameters

    Both the report and subreport have the same input parameter. When you run the report, it prompts for the same parameter multiple times. Any suggestions on how to have Access prompt for the same parameter once?
    The main report and subreport have the same keys. They just display different information.

    Thanks.

  2. #2
    Join Date
    Dec 2003
    Location
    Dallas, TX
    Posts
    1,004
    Hi jpatton and Welcome to the Forum

    Just checking, but are your MainReport and SubReport based on the same query or different queries??

    Bud

  3. #3
    Join Date
    Oct 2004
    Posts
    2
    The main report and subreport are based on similar but different queries.

    Thanks,
    JPatton

  4. #4
    Join Date
    Nov 2003
    Location
    LONDON
    Posts
    238
    You should only set the input parameter on the main report. The sub-report is filtered automatically based on the linking fields you have placed in the linkMaster, LinkChild property of the sub report

    Regards
    Justin

  5. #5
    Join Date
    Nov 2003
    Location
    LONDON
    Posts
    238
    Another thought, you could use the following;

    Docmd.OpenReport command to open the main report, but use the WhereCondition (the WHERE clause but without the word WHERE) property of the Openreport command to filter the SQL of the main report.

    regards
    Justin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •