Results 1 to 3 of 3
  1. #1
    Join Date
    Apr 2003

    Unanswered: Virtual Host Addressing on Oracle9iAS

    We have Oracle9iAS installed on Windows-2000 (SP-4) OS. Both the Instances of Oracle9iAS i.e INFRA & Mid-Tier is installed on the same machine. Our applications developed in Forms/Reports9i is deployed successfully on Mid-Tier and working OK over web with URL:: http://<Host IP>:7779/<app_name>/myprog.html
    [HTTP server running on Port 7779, <app_name> is application delployed in our OC4J Instance & myprog.html is first page which opens by above URL is kept in its relevant directory of deployed application]

    Now, i want to create a Virtual Host Address for my application that is running by HTTP Server in Mid-Tier Instance so that above URL could be avoided and intutive name can be given for the URL. I do not wish to give IP, Port etc. in URL for opening my applicaiton deployed on Mid-Tier. I wish to open like IGFL.XEXP.COM (The relevant DNS entry is already placed in Main Domain Controller machine, which will redirect to this HOST).

    I checked the documents on Metalink and followed the DocID: Note: 231351.1. I followed the steps of configuraiton without webcache setup, but this is not working properly and i am unable to trace it...Why so.?? Here, i am specifying my customized document root directory instead of AS default directory.

    Can anyone give me steps how to do it or help me identifying what i am missing. People claim that it works, but i do not hv any idea and doing it for the first time. You help is needed....Expecting your response.

    Kamesh Rastogi
    Indo Gulf - Jagdishpur
    - KR

  2. #2
    Join Date
    Aug 2003
    Where the Surf Meets the Turf @Del Mar, CA
    Provided Answers: 1
    > I wish to open like IGFL.XEXP.COM
    This problem is really not an Oracle problem.
    This problem is an Apache & networking problem.
    By default HTTP will go to port #80.
    If Apache is listening on a port other than 80, you'll need to use an F5 or similar port redirector.
    To change in which directory Apache looks fior files, you'll need to change httpd.conf file for Apache.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  3. #3
    Join Date
    Dec 2003
    Oklahoma, USA
    I agree with anacedent -- this is an apache problem, not Oracle. Would suggest you look at the "ProxyPass" parameter and set it in your httpd.conf file.
    save disk space, use smaller fonts

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts