Results 1 to 9 of 9
  1. #1
    Join Date
    Oct 2004
    Posts
    4

    Unanswered: Heeelp - Problem with oninit -yiv

    Hi everybody,

    I installed Informix IDS 9.30 in Red Hat 9.0. I solved all the problems with these libraries:
    ln -s /usr/lib/libncurses.so /usr/lib/libncurses.so.4
    and
    rm /var/lib/libpthread.so.0

    I configured the onconfig file with this options:
    ROOTNAME rootdbs
    ROOTPATH /dev/raw/raw1
    SERVERNUM 0
    DBSERVERNAME idb_on
    DBSERVERALIASES idb_shm
    NETTYPE soctcp,4,90,NET
    NETTYPE ipcshm,4,90,CPU

    When I initialize the database server, it shows me the following lines:
    Checking group membership to determine server run modesucceeded
    Reading configuration file '/opt/informix/etc/onconfig'...succeeded
    Creating /INFORMIXTMP/.infxdirs ... succeeded
    Creating infos file "/opt/informix/etc/.infos.idb_on" ... "/opt/informix/etc/.conf.idb_on" ... succeeded
    Writing to infos file ... succeeded
    Checking config parameters...succeeded
    Allocating and attaching to shared memory...succeeded
    Creating resident pool 1098 kbytes...succeeded
    Creating buffer pool 10002 kbytes...succeeded
    Initializing rhead structure...succeeded
    Initializing ASF ...succeeded
    Initializing Dictionary Cache and SPL Routine Cache...succeeded
    Bringing up ADM VP...

    But it stops and doesn't finish the process, without showing me any error message.

    I revised every file 1000 times (onconfig, sqlhosts, hosts, services) and have changed the onconfig file values, but haven't found out why the process just stops.

    I'm grateful to at least have discovered "ipcclean" to "clean" the shared memory every time that the process failed.... ;-)

    Please, please, please.... help me.

    Sincerely,

    Eeedu

  2. #2
    Join Date
    Aug 2004
    Posts
    19
    This sounds like a problem I had with IDS 9.40 on a Red Hat 7.3 server, where the sysadmin had accidentially loaded a non-mp upgrade to the glibc package, though we were running a mp kernel. Once he loaded the correct glibc version, Informix finally started right up. Sorry I can't offer more advice.

  3. #3
    Join Date
    Oct 2004
    Posts
    4
    Thanks,

    It's a new installation. Immediately after installing Red Hat 9 I installed IDS. That's why I think it must be a configuration problem.

    The worst part is that I did the same installation process a while ago and it worked... everything appears the same but now it won't work. I don't understand.

    Thanks for your help.

  4. #4
    Join Date
    Nov 2004
    Posts
    7
    you can´t set the SERVERNUM = 0

    you have to change this parameter to anything greater 0

  5. #5
    Join Date
    Aug 2003
    Location
    Argentina
    Posts
    780
    Hi,

    Please test following:
    Remove simbolink links "rm /var/lib/libpthread.so.0", next as user Informix, run
    ldd $INFORMIXDIR/bin/oninit, next start-up.

    Gustavo.

  6. #6
    Join Date
    Oct 2004
    Posts
    4
    Gustavo,

    I already deleted the file /var/lib/libpthread.so.0 but I received the same response.

    Any idea????

    Please..

  7. #7
    Join Date
    Nov 2004
    Posts
    60

    Me too!

    I have exactly the same thing on SuSE 9.0 Linux, glibc 2.3.3-98 and kernel 2.6.5 - Informix Version 9.40.UC5

    Stops at Bringing up ADM VP and the online log shows:

    Mon Nov 22 22:52:37 2004

    22:52:37 Event alarms enabled. ALARMPROG = '/opt/informix/etc/alarmprogram.sh'
    22:52:37 Booting Language <c> from module <>
    22:52:37 Loading Module <CNULL>
    22:52:37 Booting Language <builtin> from module <>
    22:52:37 Loading Module <BUILTINNULL>

    If anyone knows what to do to fix this I would be most grateful.

  8. #8
    Join Date
    Nov 2004
    Posts
    60
    fixed this as follows:

    Set NETTYPE in the onconfig to onsoctcp,1,90,CPU
    Set entry for the machine in sqlhosts as follows:
    ol_hostname onsoctcp hostname servicename

  9. #9
    Join Date
    Aug 2003
    Location
    Argentina
    Posts
    780
    Hi eedu,

    You need to do upgrade up of library glibc.

    Gustavo.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •