Results 1 to 9 of 9
  1. #1
    Join Date
    Aug 2003
    Location
    Ohio
    Posts
    38

    Unanswered: DB2COMM Setting disappears

    Hi!
    We had a problem 2 times now that when our Unix machine is bounced, it "looses" it's setting for DB2COMM. All the other settings seem to be okay. My understanding is that you only need to set this once, and it should remember it through reboots. Am I correct? Do I need to put it in the .profile or something?

    Thanks!
    Jodie

  2. #2
    Join Date
    Apr 2004
    Location
    Inside Intel
    Posts
    165

    Talking

    Use:

    1. db2set DB2COMM=tcpip
    2. Stop and start the instance

    HTH,
    Newbie

  3. #3
    Join Date
    Aug 2003
    Location
    Ohio
    Posts
    38

    Question

    Quote Originally Posted by dsusendran
    Use:

    1. db2set DB2COMM=tcpip
    2. Stop and start the instance

    HTH,
    Newbie

    We've done this. My problem is every once in a while, after a system reboot, the setting disappears for one of my instances (but not the other 2).

    My questions are: Should this maintain after reboot? What would cause it to loose it's setting? Do we need to set it in a .profile or something

  4. #4
    Join Date
    Apr 2004
    Location
    Inside Intel
    Posts
    165
    No idea. My settings on the DB2 (on a Solaris box) are retained even after reboot. Did you check the diaglog.log file?

    See if the setting was retained if you did a db2stop and db2start (ie DBM retstart)

  5. #5
    Join Date
    Aug 2003
    Location
    Ohio
    Posts
    38
    Quote Originally Posted by dsusendran
    No idea. My settings on the DB2 (on a Solaris box) are retained even after reboot. Did you check the diaglog.log file?

    See if the setting was retained if you did a db2stop and db2start (ie DBM retstart)

    I checked the db2diag.log. The only messages I have are as follows:
    Code:
    2004-11-04-23.20.26.813109   Instance:db2inst1   Node:000
    PID:11588(java)   Appid:
    common_communication  sqlcctcpconnr   Probe:110 
    DIA3202C The TCP/IP call "connect" returned an errno="22".
    These started last night around 23:20. Our sysadmin noticed the application wasn't working around 3:00 am (don't ask why he was on the system then! ) He then rebooted the whole machine. When I got in, I found out about the problem.

    And, like I said, the DB2COMM was set for the other 2 instances just fine. It's just one of them I have problems with. I'm baffled.

    Any other ideas?
    Jodie

  6. #6
    Join Date
    Mar 2004
    Posts
    448
    Under db2 home directory under sqllib there is a file profile.env.
    It contains the db2 profile registry like DB2COMM . check that
    it contains the that registry parameter, using the command
    more profile.env.

    This is the file that instance read for finding the registry parameters.

    Check file permissions. I think this should be a problem,


    regards

    Mujeeb

  7. #7
    Join Date
    Apr 2004
    Location
    Inside Intel
    Posts
    165

    Arrow

    What version of DB2 are you on? What level of fixpak? Try reading the APARList associated with the fixpak. Maybe this is a known bug fixed at a later fixpak.

    Sorry couldnt help you there.

    Newbie

  8. #8
    Join Date
    Aug 2003
    Location
    Ohio
    Posts
    38
    Mujeeb -
    Thanks for the info on the profile.env. I checked it, but it's in there:

    Code:
    $> more profile.env
    DB2ENVLIST='EXTSHM'
    DB2COMM='TCPIP'

    Newbie -
    I'm on Version 7, FixPack 10A.

    I've now set the parameter at the global level instead of just at the instance. I'll start looking at APARs to see if I find anything.

    Thanks!
    Jodie

  9. #9
    Join Date
    Aug 2003
    Location
    Ohio
    Posts
    38
    Just in case anyone else ever has this problem -

    I put in a PMR on this, and the problem was that our SysAdmin had added a second Ethernet card, and gave it the same dns-name as the first one.

    Thanks!
    Jodie

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •