Results 1 to 13 of 13
  1. #1
    Join Date
    Nov 2004
    Posts
    7

    Unanswered: Install Oracle 8i and 9i on a single Sun Solaris Box?

    I already have Oracle 9.2.0.4 on the machine. Now I want to install
    Oracle 8.1.7 on it. Is there any guideline that I can follow?

    Here is the OS machine of Solaris:
    bash-2.03$ uname -a
    SunOS luckbox 5.8 Generic_108528-23 sun4u sparc SUNW,Sun-Fire-V240


    Thank you,
    Jim

  2. #2
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  3. #3
    Join Date
    Jan 2004
    Posts
    18
    Hi

    create a new user for example ora8 in dba group, so follow the installation guide working as that user. Therefore you must always use this user in Oracle 8i operations
    Murat SULUHAN
    Live Free or Die

  4. #4
    Join Date
    Nov 2004
    Posts
    7
    I sucessful installed the Oracle 8i software. However, I met the following
    errors during the database creation:

    ORA-03114: not connected to ORACLE

    If I chose "ignore," a few other errors would appear:
    ORA-27101:shared memory realm does not exist
    ORA-01012:not logged on
    ORA-01034:ORACLE not available

    What are the possible reasons? How could I solve the problem?

    Thanks,
    Jim

    The following settings are fine for the existing Oracle 9i.
    set semsys:seminfo_semmni=100
    set semsys:seminfo_semmns=5000
    set semsys:semingo_semmsl=1024
    set shmsys:shminfo_shmmax=4294967295
    set shmsys:shminfo_shmmin=1
    set shmsys:shminfo_shmmni=1024
    set shmsys:shminfo_shmseg=10

  5. #5
    Join Date
    Nov 2002
    Posts
    833
    did you set wrong parameters ???
    what is your .profile contents?
    are you mixing up 9i with 8i home ?
    trying to create a 8i instance while env is set to 9i???

  6. #6
    Join Date
    Jul 2003
    Posts
    2,296
    most likely you need to set up "oratab" and your environment correctly.

    cat /var/opt/oracle/oratab
    file should have something like this:
    9iSID:/apps/oracle/9.2:N
    9iProd:/apps/oracle/9.2:N
    8iSID:/apps/oracle/8.1.7:N


    then before you create your db, be sure to set the environment using ORAENV

    bin.bash> . oraenv
    ORACLE_SID = [oracle] ? pgoldbat


    now connect as internal or sysdba and run your create scripts
    sqlplus internal
    <SQL> @create_mynew8idb.sql
    - The_Duck
    you can lead someone to something but they will never learn anything ...

  7. #7
    Join Date
    Nov 2004
    Posts
    7
    Here is the information in oratab:

    cat /var/opt/oracle/oratab
    NINEIDB:/oracle/home:Y
    EIGHTIDB:/u01/app/oracle/product/8.1.7:N

    I use "Express Installation" to install Oracle 8i Enterprsie Edition.
    The first phase (Oracle Software installtion) was successful.
    But OUI met those errors when it tried to create a starter database
    ( I chose ignore so the installation completed with warnings).
    Later when I tried to use dbassist to create a new database,
    the same errors appeared. I aborted the creation this time.

    So I do not think that the starter datase was created successfully.

    Thank you,
    Jim

  8. #8
    Join Date
    Jul 2003
    Posts
    2,296
    create one manually and see if it works.
    - The_Duck
    you can lead someone to something but they will never learn anything ...

  9. #9
    Join Date
    Nov 2004
    Posts
    7
    How to create one manually?
    I used dbassist, and it was the same errors.

    THanks,
    Jim

  10. #10
    Join Date
    Jul 2003
    Posts
    2,296
    GUI = death (aka: no knowledge)
    do you really learn anything by running dbassist?

    it is fairly simple and takes a minumal amount of effort and time.
    below are a few links:
    Code:
    http://download-west.oracle.com/docs/cd/B10501_01/server.920/a96521/create.htm#1000691
    
    http://www.adp-gmbh.ch/ora/admin/creatingdbmanually.html
    - The_Duck
    you can lead someone to something but they will never learn anything ...

  11. #11
    Join Date
    Jan 2004
    Posts
    18
    Hi jxcheng

    You have to setup the environment variables for oracle 8i user,

    I have 4 different version of Oracle databases in the same system with different users.

    Sorry for delayed update, we have official holiday.
    Murat SULUHAN
    Live Free or Die

  12. #12
    Join Date
    Nov 2004
    Posts
    7
    I do have set the ENVIRONMENT varaibles to ORacle 8i.
    The GUI (OUI or dbassist) just does not work properly.
    In the end, I modified the db creation scripts from the articles, and successfully created a database manually.

    Thank all of you for the help.

    Jim

  13. #13
    Join Date
    Jul 2003
    Posts
    2,296
    JIM!

    Well done!
    - The_Duck
    you can lead someone to something but they will never learn anything ...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •