Results 1 to 2 of 2
  1. #1
    Join Date
    May 2002
    Location
    Sydney
    Posts
    45

    Question Unanswered: xp_cmdshell & WrapperRead() error

    Hi all,

    SQL Server 2000 SP3a, SAN Connection, Standard Edition, 2000 Server edition OS.

    I've implemented a log shipping program on one set of sql servers already, the SVR1 set, which are working fine.
    I am implementing this on the SVR2 set and I have the wrapperread() problem.
    All using SP3a, with MDAC version outlined below. All are reported to be running the SP1 Refresh.

    SVR1 - 2.7 SP1 Refresh
    SVR1_DR - 2.7 SP1 Refresh

    SVR2 - 2.7 SP1 / 2.7 SP1 Refresh
    SVR2_DR - 2.7 SP1 / 2.7 SP1 Refresh

    When executing the command below in T-SQL I get the error below.
    EXEC @sentok = master.dbo.xp_cmdshell @cmd

    [Microsoft][ODBC SQL Server Driver][Named Pipes]ConnectionRead (WrapperRead()).
    Server: Msg 11, Level 16, State 1, Line 0

    Any help would be gratefully accepted.

    Regards,
    JS

  2. #2
    Join Date
    May 2002
    Location
    Sydney
    Posts
    45
    Hi,

    Just thought i'd mention, the code runs for about 8 seconds before falling over.

    I have MDAC 2.8 on my client pc, which I am using to fire off the commands on the primary server which is using MDAC 2.7 to the DR server which is using 2.7

    Thanks,

    JS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •