Results 1 to 5 of 5
  1. #1
    Join Date
    Nov 2004
    Posts
    4

    Exclamation Unanswered: ADO doesn't connect without network!

    Hi!

    I wrote an application which connects to a SQL Server / MSDE 2000 DB through ADO components. Now the application doesn't start if I don't have an active network connection; as far as I try to connect, the error I get is:

    [DBNETLIB][ConnectionOpen (Connect()).].........

    Everything is ok if I simply plug the network cable and let the PC connect to the TCP/IP network.

    Hope someone can help me!
    Thanks

    Umberto

  2. #2
    Join Date
    Nov 2004
    Posts
    4

    I forgot....

    ...Of course the DB is located on the same PC than the application!

    Umberto

  3. #3
    Join Date
    Nov 2004
    Posts
    4

    New indication....

    If I write

    Data Source=PC_NAME

    instead of

    Data Source=127.0.0.1

    it works fine! Now the question is: WHY??????

    Umberto

  4. #4
    Join Date
    Mar 2004
    Posts
    114
    Is it MSDE or SQL Server Std ?

    If MSDE, have you installed Netlib ? It is lhe parameter
    Code:
    DISABLENETWORKPROTOCOL=0
    in setup.ini or command line parameters

  5. #5
    Join Date
    Nov 2004
    Posts
    4

    Solution

    Finally I solved the problem by writing:

    .....;Data Source=(local);.....

    in the connection string!

    Thanks
    Umberto

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •