Results 1 to 3 of 3
  1. #1
    Join Date
    Nov 2004
    Posts
    1

    Unanswered: Installing Oracle 10g under Slackware LInux 10

    Hi,

    I downloaded Oracle 10g for Linux x86-32 but when I ran the installer it basically said that I needed RedHat.

    I don't want RedHat :)

    I think I've seen a post in this forum somewhere which implied someone had managed to install Oracle 10g on Slackware 10 and so my question is "is it possible?".

    Any advice greatly received.

    Thanks,

    --
    Sean

  2. #2
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    Google is your FRIEND!

    ./runInstaller -ignoreSysPrereqs
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  3. #3
    Join Date
    Dec 2004
    Posts
    1

    Slackware install

    I too am interested in installing Oracle on Slackware.

    I followed all the pre-installation steps ( Except having Redhat Linux )
    Running Ignore Sysprereqs worked to a point.

    During linking is where I had a problem... once for ctx lib ... fixed added to ld.so.conf,
    and again for rdbms/lib ... here's the problem there aren't any .so files here... I figure that means it needs to be compiled... but I couldn't get the make file to run.

    Error from Oracle Universal Installer:
    Error in invoking 'ishsodbc ctx_on' of makefile /oracle/app/oracle/OraHome_1/rdbms/lib/ins_rdbms.mk

    Seeing that I tried to run the make file manually:

    Error that occurred from Make:
    oracle@libertas:/oracle/app/oracle/OraHome_1/rdbms/lib$ make -f ins_rdbms.mk
    ins_rdbms.mk:2: /rdbms/lib/env_rdbms.mk: No such file or directory
    ins_rdbms.mk:26: target `ksms.s' given more than once in the same rule.
    make: *** No rule to make target `/rdbms/lib/env_rdbms.mk'. Stop.
    oracle@libertas:/oracle/app/oracle/OraHome_1/rdbms/lib$

    If anyone can clue me in to how to fix this I'd appreciate it greatly. (other than running red-hat. I need the slack machine and don't have another machine handy.... besides nothing wrong with slack.)

    -Steve

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •