Results 1 to 6 of 6
  1. #1
    Join Date
    Dec 2004
    Posts
    2

    Unanswered: Primary filegroup full SQL error 42000

    (SQL SERVER 2000)

    I keep getting the "primary filegroup is full" error when ever I try to write data even though the following things are true:

    allow unlimited growth set for BOTH database and transaction log
    auto shrink and auto update statistics flags are set in database options
    growth set to 10 percent for both
    database is 4GB but disk has 12GB freespace
    transaction log is on same disk but is only 8MB ???

    SQL shows the database has 2% free space but any attempts to write cause the error, shrinking drops this to 1% but still produces the same error on writes

    SQL shows the transaction log has 90% free space

    backup maintenance plans are in operation for both transaction log and database (write to different drive)


    I am completely confused!

  2. #2
    Join Date
    Nov 2002
    Location
    Jersey
    Posts
    10,322
    Google's a wonderful thing

    http://support.jodohost.com/showthread.php?t=981

    Try bumping up the percent growth

    I don't personally like to set to autogrow...the database should be managed to meet particular expectations, you should predicate the growth, and set alerts to imform you when your reaching those limits...

    But I betcha that should fix it.
    Brett
    8-)

    It's a Great Day for America everybody!

    dbforums Yak CorralRadio 'Rita
    dbForums Member List
    I'm Good Once as I ever was

    The physical order of data in a database has no meaning.

  3. #3
    Join Date
    Dec 2004
    Posts
    2

    More of the same

    Changed the growth percentage to 80% restarted SQL server agent shrank database, tried the write operation SAME ERROR! But now refuses to perfrom the transaction log backup but only give a general fail error, yet the drive still has 12GB free space!!!!

    For some reason it just won't go beyond the 4GB size, weird, is Windows 2000 Server anything to do with it??

  4. #4
    Join Date
    Feb 2004
    Location
    In front of the computer
    Posts
    15,579
    Provided Answers: 54
    Any chance you might have installed MSDE on that machine? According to the Capacity Specifications, MSDE has a 2 Gb limit on the data portion of a database that might be causing havok.

    -PatP

  5. #5
    Join Date
    Jul 2003
    Location
    San Antonio, TX
    Posts
    3,662
    If that was MSDE the poster wouldn't have had 4GB worth of data.
    "The data in a record depends on the Key to the record, the Whole Key, and
    nothing but the Key, so help me Codd."

  6. #6
    Join Date
    Aug 2011
    Posts
    1

    fix Primary File is Full

    Hi

    every time run a DTS to certain task, error message said that primary file is full, but i have no idea where is full,my server is freediskspace and TRans log and data also ok.

    need to get a solution to fix it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •