Results 1 to 4 of 4
  1. #1
    Join Date
    Nov 2004
    Connecticut USA

    Talking Unanswered: Db2start command is not issued

    I am a new user to DB2. I am running the DB2 Enterprise Edition v8.1 on a Windows XP OS. I had 8.1 earlier and had installed 8.2 when my system started giving me this error.
    Now I am back to version 8.1 but the problem seems to have followed me.
    The entire error code had been given below for reference.

    12-03-2004 12:10:03 0 0 SQL1032N No start database manager command was issued. SQLSTATE=57019

    This error comes up when I give the "db2start" command at the command line prompt.
    I am sure that this might seem like something simple for a lot of you but as a beginner I am stumped.
    I have tried going through to the services under administrative tools and start it as well. It gives me an error there as well.
    Not at all a priority issue but I would apprecaite it whenever it is resolved since it is holding me up right now.
    I thank everyone who even looks at this post and also if you try to resolve it.
    Best regards,
    Last edited by mrupadhyay; 12-09-04 at 14:12. Reason: Problem Solved :)

  2. #2
    Join Date
    Jul 2003
    Austin, TX, USA


    Hi Mayank,

    Can you please post us a snapshot of the db2diag.log which should be found under the sqllib directory.

    That should give us some reason. Also check for the event log under windows eventlog for any clues. Post that also if available.

    Hopefully we should be able to diagnose something from it.


    Ask the experienced rather than the learned

  3. #3
    Join Date
    Nov 2004
    Connecticut USA

    Talking Thanks

    Hey Nitin,
    Thanks for looking into my problem. I realized that the evaluation period for my edition had expired and that was the reason it was not letting me start the DB2 instances and the DAS.
    I re-intalled a licensed version and now it is working fine.
    Guess I am still a doofus when it comes to technicalities
    Sorry for taking your time.
    Much appreciated.

    Below is the excerpt from the DB2diag.log if you are still interested:

    2004-12-03- Instance : DB2CTLSV Node:000
    PID:1356(db2syscs.exe) TID:788 Appid:none
    oper system services licRequestAccess Probe:2

    SQL8008N The product "DB2 Enterprise Server Edition" does not
    have a valid license key installed and the evaluation period
    has expired. Functions specific to this product are not enabled.

    Thanks a lot though for looking into my post.

  4. #4
    Join Date
    Sep 2004
    Use db2licm -l command to check the licence period.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts