Results 1 to 6 of 6
  1. #1
    Join Date
    Dec 2004
    Posts
    4

    Unanswered: RMAN-06019 CAN NOT TRANSLATE TABLESPACE "TOOLS"

    hi everybody,
    i am using rman for my backup and recovery activities.i have deleted tablespace named tools and tried to restore it with rman.following is the result of restore command.
    please help me in this regard.
    it is working properly if i execute same steps for datafile.it is failing for tablespace.please look into this

    RMAN> restore tablespace tools;

    Starting restore at 07-DEC-04

    using channel ORA_DISK_1
    RMAN-00571: ================================================== =========
    RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
    RMAN-00571: ================================================== =========
    RMAN-03002: failure of restore command at 12/07/2004 13:02:35
    RMAN-06004: ORACLE error from recovery catalog database: RMAN-20202: tablespace not found in the recovery catalog
    RMAN-06019: could not translate tablespace name "TOOLS"

  2. #2
    Join Date
    Jul 2003
    Posts
    2,296
    DELETE a tablespace? do you mean DROP?
    Did you execute DROP TABLESPACE?
    Or did you delete the datafile?

    If you dropped the tablspace then you need to recover the database
    to a point in time, not the tablespace.

    Did you take the tablespace offline before you tried to restore?

    The steps you took make all the difference.
    - The_Duck
    you can lead someone to something but they will never learn anything ...

  3. #3
    Join Date
    Dec 2004
    Posts
    4
    hi ,
    this is prashanth reddy.i tried to solve the problem with your seggestion.but it didn't work.because i don't have datafile with me.ilost it along with the tablespace.i droped tablespace along with datafile

    regards
    prashanth reddy

  4. #4
    Join Date
    Oct 2004
    Posts
    145
    If this is not a critical system and you are testing.

    Try rman recovery command in conjunction with the
    "using backup controlfile"

    You may need to fool the system to think it still has the tablespace TOOLS. If you did not backup the control file, I am out of suggestions. Maybe do a complete restore from the rman backup you performend.

  5. #5
    Join Date
    Oct 2004
    Posts
    7
    1234567890
    Last edited by tertiusluke; 12-09-04 at 18:29.

  6. #6
    Join Date
    Oct 2004
    Posts
    7
    If you dropped the tablespace with the "DROP TABLESPACE TOOLS..." sql command you have a couple of options with RMAN.

    1) You can try the "Tablespace Point in Time Recovery" which you can read about (version 9.2) here:
    http://download-west.oracle.com/docs...pit.htm#449254

    If you choose this option you'll need to be using a Recover Catalog Database in your configuration.

    2) If you don't mind losing all of the data that has been added to your other tablespaces since the time you dropped your TOOLS tablespace, you can perform an incomplete recovery of the entire database. In RMAN the way you do this is:

    run{
    SET UNTIL TIME "to_date('20041209:12:12:12','yyyymmdd:hh24:mi:ss' )";
    restore database;
    recover database;
    }

    Option 1 basically has you do option 2 in a separate "CLONED" database and then has you export/import the tablespace back into your original database.

    David Kimery
    Oracle DBA, Instructor
    OCP 7,8,8i,9i

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •