Results 1 to 2 of 2
  1. #1
    Join Date
    Aug 2004
    Posts
    2

    Unanswered: MYSQL Error When Inserting a New Record...

    I'm getting the following error when inserting a new record on a registration form.

    An error occured. -2147467259 : SQLState: S1000 Native Error Code: 1142 [TCX][MyODBC]insert command denied to user: 'cpanelname_username@localhost' for table 'tablename'

    I've tried almost everything except for trying to insert into a different table or use a different command. I've tried inserting a single record without populating from the form, but it gives the same error.

    My user has full privileges and has been added as full to the database I'm accessing.

    Though I haven't tried yet, the only thing that I can think that may be causing this is that I am submitting information to all fields and that includes the Primary Key. However, my PK isn't set to auto increment so it shouldn't matter.

    If anyone has any information about this I would greatly appreciate it. Thanks!

    Arvida

  2. #2
    Join Date
    Jun 2002
    Posts
    63
    Surely this has gott to be an 'access' issue. Try explicitly granting rights to the user on the specific database in question.

    -> there is one other thing, how r u trying to access the database, I believe that there was a change on the way that MySQL handles passwords, I had problems with PHP and MySQL, becuase PHP didn;t support the new version passwords on MySQL. There is a configuration option in the mysql conf file to endable 'old passwords' I think.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •