I was trying to update the database using updategrams. I have tried using it works out fine with xml and the xdr schema but it i try to do the same with xsd schema it gives the mapping error. I have tried these things with the MSDN examples but ...
kindly help me if you have any idea.

the xml file and xdr file that are working are:
xdr file with name SampleUpdategram
<?xml version="1.0" ?>
<Schema xmlns="urn:schemas-microsoft-com:xml-data"
xmlns:dt="urn:schemas-microsoft-com:datatypes"
xmlns:sql="urn:schemas-microsoft-com:xml-sql">
<ElementType name="COrder" sql:relation="CustOrder" >
<AttributeType name="OID" />
<AttributeType name="EID" />

<attribute type="OID" sql:field="OrderID" />
<attribute type="EID" sql:field="EmployeeID" />
</ElementType>
</Schema>

the xml files thast uses this xml is

<ROOT xmlns:sql="urn:schemas-microsoft-com:xml-sql"
xmlns:updg="urn:schemas-microsoft-com:xml-updategram">
<updg:sync mapping-schema='SampleSchema.xml'>
<updg:after>
<COrder OID="98451" EID="7" />
</updg:after>
</updg:sync>
</ROOT>


where custOrder is a simple table with fields: OrderID and EmployeeID.

but when we have replaced this xdr schema with xsd schema as shown below, we got the error

xsd schema
<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:sql="urn:schemas-microsoft-com:mapping-schema">
<xsd:element name="CustOrder" >
<xsd:complexType>
<xsd:attribute name="OrderID" type="xsd:integer" />
<xsd:attribute name="EmployeeID" type="xsd:integer" />
</xsd:complexType>
</xsd:element>
</xsd:schema>

and the error is:
<ROOT xmlns:sql="urn:schemas-microsoft-com:xml-sql" xmlns:updg="urn:schemas-microsoft-com:xml-updategram">
<?MSSQLError HResult="0x80004005" Source="Microsoft XML Extensions to SQL Server" Description="Specified attribute or element ('CustOrder') does not have a corresponding mapping in the schema, and no overflow field defined"?>
</ROOT>