Results 1 to 1 of 1
  1. #1
    Join Date
    Oct 2004

    Question Unanswered: PGPool on Cygwin?

    Hi all, I wonder if anyone can help with this problem (or at least has experienced it!)

    I'm trying to use the PGPool 2.3.1 program (which hopefully someone here has heard of...) to provide replication of two PostgreSQL databases. For various reasons, use of a native Linux / UNIX system to run the program isn't really an option, and so I'm trying to get it to run in Cygwin. It compiled without any problems, and appears to be working in most instances, except when I try to actually use the replication feature, where the secondary server doesn't get updated. Using the console loggin feature in PGPool (-n option), I've found that for some reason, the program can't connect to the secondary server (claiming connection refused). I've tried switching the order of the servers in the PGPool config file, but I still get exactly the same problem (i.e. connection to secondary server fails, regardless of which server it is).

    One more thing I should add, is that the two servers are running different versions of PostgreSQL. Could this be the cause?

    I've done a bit more searching, and found that this is the problem.

    Any ideas will be much appreciated!

    (btw, apologies if I've posted this in the wrong place, but the PostgreSQL thread seemed most appropriate).
    Last edited by Ocean Soul; 01-05-05 at 09:43. Reason: A solution (sort of, I know what's wrong anyway)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts