When I copy ,dbf files froom the server to a CD the read-only box is unchecked (non read only). When I copy these files to run a VB6 program the files are all now marked as read-only. I have to manually change them to or uncheck the read-only box. Is there a way that when I copy these files from the CD to the hard drive to make them non read-only (read-only unchecked) without having to do this manually? your help would be appreciated.