Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2004

    Question Unanswered: DB2 to Access 97 Timestamp Issue

    We are having a problem with linking tables in MS Access 97 to DB2/OS 390 ver 8 tables that have a time stamp column. All the records come back with "#Name?" in each column and an "ODBC call failed error."

    I have set up the CLI parameter to accept the "Patch 1" service, with the value "Describe time stamps as a Char(26)" selected. This is what we use to do for ver 7 of DB2. That worked as desired.

    I also wasn't sure if the CLI settings were being cashed on the machine after being used once or not. We even tried shutting down the machine to ensure that wasn't the case, but still no luck.

    Any help would be usefull.

    Thank you.

  2. #2
    Join Date
    Nov 2004
    Provided Answers: 4
    I don't know if this will help, but I remember having problems too with Access timestamps, the solution then was using this notation : {ts '2004-12-09 17:35:03'}

    There is also an incopatibility problem between DB2 TIMESTAMPS and Access DATETIME formats. Perhaps this or this can help.


  3. #3
    Join Date
    Feb 2012

    DB2/UDB ODBC Timestamps as char(26)

    I had the same issue and tried various CLI/ODBC recommendations from IBM. My initial attempts failed configuring my Data Source with


    Also neither PATCH1 or PATCH2 worked, only after further research did on stumble on DateTimeStringFormat=USA did my Microsoft Access application report the standard IBM ISO char(26) format.

    My recommendation would be to add the following parameters:


    Please note that if you have linked the table into Microsoft Access prior to making these CLI/ODBC settings then you will need to delete the linked table and re-link it.

    Good Luck

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts