Results 1 to 3 of 3
  1. #1
    Join Date
    Apr 2003
    Location
    Melbourne, Australia
    Posts
    53

    Unanswered: Creating Database manually

    hi All,

    I am trying to create an oracle v8.1.5 database manually. Using the net8 assistant i have created the entry for the SID to be used and i am able to tnsping to the SID name. However, when i connect using svrmgrl it gives the following error

    ORA-12514: TNS:listener could not resolve SERVICE_NAME given in connect descriptor

    here's copy of the tnsnames.ora

    ID =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(PORT = 1527)(HOST = abc))
    )
    (CONNECT_DATA =
    (SERVICE_NAME = ID)
    )
    )

    The sqlnet.ora file is as follows

    SQLNET.EXPIRE_TIME = 0
    NAMES.DIRECTORY_PATH= (TNSNAMES)

    Any ideas on wht i am missing

  2. #2
    Join Date
    Dec 2004
    Location
    Memphis
    Posts
    25

    Post

    Hello Rupee,

    First, connect to the instance using this setting, type show parameter service_name Or

    Select * from v$parameter where name = 'service_name'

    and compare the result with the service_name string in tnsnames.ora According to the error message, they aren't equal.
    NewKid

    A Newkid in the block

  3. #3
    Join Date
    Dec 2004
    Location
    Apeldoorn, the Netherlands
    Posts
    9
    You did do the following?

    I assume the database is not yet there?

    * open dos-box (assuming you are on windows. Yes, a lot of assumes, but then again, you do not post what you are using.. )

    set ORACLE_SID=ID
    svrmgrl
    connect internal
    create database ID ....etc.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •