Results 1 to 3 of 3
  1. #1
    Join Date
    Dec 2004
    Posts
    3

    Unanswered: How to increase the SQL Server memory

    We are using SQL server 7.0, our users use to connect to SQL server remotely using Visual Basic Application. When all the users are connected it keeps on increasing the memory utilization and at 1,836,848 KB memory utilization it stops increasing the memory i.e memory utilization become stangnet. The actual amount of physical Memory is around 5GB but SQL server dont increase it after the treshhold level and the performance of the server get affected badly. Any one please suggest me the possible solution.

  2. #2
    Join Date
    Feb 2004
    Posts
    78
    In Enterprise Manager,
    - right click on the server name and choose properties.
    - choose memory tab

    You should be able to set your min/max memory settings there. Also look into worker threads (on the processor tab).

    Something else to think about,
    How big is the DB (Gigs) ? How big are the tables being referenced? Perhaps something could be re-designed to make things more efficient. Are there a lot of table scans where you could have indexes, etc..?

    Also,
    Open the performance moniter and check the sql counters..

    More info at -> http://www.sql-server-performance.co...nitor_tips.asp

  3. #3
    Join Date
    Jul 2003
    Location
    San Antonio, TX
    Posts
    3,662
    It looks like you're running Standard Edition of SQL2K, which will not recognize any more memory, period! You need to upgrade to Enterprise and then you'll have more options:

    1. /3GB in boot.ini will allow SQL Server to use more than the default 2GB
    2. /PAE in boot.ini and enabling AWE on SQL Server will give SQL service whatever amount you specify.
    "The data in a record depends on the Key to the record, the Whole Key, and
    nothing but the Key, so help me Codd."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •