Results 1 to 9 of 9
  1. #1
    Join Date
    Jan 2003
    Posts
    106

    Unanswered: File too large error on HP-UNIX when importing data for a database

    Hi,

    When we were importing data for a particular database it gave file too large error.

    Whenever the size of the dbf file grows beyond 4gb we get this error.

    Is there any kernel settings or any other settings to be done from OS side to rectify this??
    Sachi

  2. #2
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,094
    Provided Answers: 4
    Check this page, perhaps it'll help.
    Hint: try to split one large export file into several smaller ones.

  3. #3
    Join Date
    Jan 2003
    Posts
    106
    I am trying to import and not export.
    Moreover when I am importing for a particular user the dbf file attached to this user is growing beyond 4 gb.Hence the problem lies with the OS seetings.So I need to know the correct settings which can handle large files.
    Sachi

  4. #4
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,094
    Provided Answers: 4
    The document says that filesize greater than 2Gb is always been a problem at most of OS. Here is another one that talks about "Can one beat the Unix 2 Gig limit?" stuff and deals with it the same way ... And here is a forum page where people talk about HP-UX and Oracle filesize limits; didn't read if from word to word, but you might.

    I've never had such a problem, but I guessed that splitting the export file might solve your problem. Are you sure it won't help? Did you actually try it? Would it cost too much to do so?

    I've seen your similar topic couple of months ago ... did you solve it?
    Last edited by Littlefoot; 12-21-04 at 14:43.

  5. #5
    Join Date
    Jun 2004
    Location
    Liverpool, NY USA
    Posts
    2,509
    If your DBF is growing beyond the max size of the Operating System, then simply add one or more datafiles to the tablespace that is being blown out. Make your datafiles with autoextend on, but a maxsize under the O/S limit. You can have more then one datafile in a tablespace.
    Bill
    You do not need a parachute to skydive. You only need a parachute to skydive twice.

  6. #6
    Join Date
    Nov 2004
    Location
    Temple University
    Posts
    36

    Cool File Size Limit

    Most versions of Unix, now have an option to specify being able to create files larger than 2G. Do not use this procedure, you are much better of limiting your dbf files to 2G. The reason for this is the ability to use DIRECT I/O. Seems that Oracle can not use this if you are using large files.

    HTH
    Peter

  7. #7
    Join Date
    Jan 2003
    Posts
    106
    No,the problem which I posted earlier is not solved.

    The export file which I was using for import had many users.Now I will try to generate an export file with just one user and try to import from that.

    I thought there is some kernel settings which restricts the file size.Actually It imports 2 gb and not beyond that.

    Now my system admin has enabled large file size at the OS level.Hence It imports data for a particular dbf till 3.7G and then says

    IMP-00009: abnormal end of export file

    doesnt return any error from OS level.

    Actually this dbf file is supposed to grow to 12GB.It works fine on solaris and windows platform except this HP-UNIX.
    Sachi

  8. #8
    Join Date
    Jan 2003
    Posts
    106
    WE GOT THIS PROBLEM rectified.The file size will not grow more than 2GB on HP-UNIX machine by default.

    You have to set largefiles options by using the command

    1.Unmount the respective mount point
    2.fsadm -F <filesystemname> -o largefiles <mount point path>
    3.mount the respetive mount point
    Sachi

  9. #9
    Join Date
    Sep 2004
    Location
    London, UK
    Posts
    565
    You asked:
    Whenever the size of the dbf file grows beyond 4gb we get this error.
    .dbf files are normally the database data files used for tablespaces.

    .dmp is the normal extension for exp/imp files.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •