Results 1 to 2 of 2
  1. #1
    Join Date
    Dec 2004
    Posts
    2

    Unanswered: Static Cursors required for snapshot support

    I have an old application (Framme) which connects to DB2 on NT fine using a StarQuest ODBC driver (version 2, 1998). In migrating to XP, I receive the error "Static Cursors Required for Snapshot Support" during standard operation. The only reference I found to this error is from Oracle (totally different circumstances) where they indicate that the user needs to upgrade the driver. Seemed logical and was done, but no change (same error using StarQuest version 5 with Framme on XP). Preparing to try DataDirect ODBC driver, but hoped someone has seen this and knows which 'button' to push.

  2. #2
    Join Date
    Dec 2004
    Posts
    2
    To clarify, the scenario of Framme (GIS) to/from DB2 on OS/390 with a StarQuest ODBC driver using NT works well and has been for several years. We are simply migrating our PCs to XP. This same application to the same database on the same system using the same driver fails as described ("Static Cursors Required for Snapshot Support"). Without a resolution, we will be unable to migrate to XP as planned. Has anyone seen this error before?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •