Results 1 to 1 of 1
  1. #1
    Join Date
    Aug 2003
    Location
    Cleveland USA
    Posts
    184

    Unhappy Unanswered: Can't compact db- Records can't be read?!?!

    I am trying to compact an Access 97 database, and I keep getting a message of "Record(s) can't be read; no read permission on C:\databasename.mdb". What does this mean?!?

    I tried "Repair" first, which ran OK, then compact, then I got the message. I then tried taking a copy (no repair this time) and compacting it, and I got the same message. The db1.mdb was left behind, and looks like an OK copy, but I really don't like that error message. This database swells to the large size pretty quickly and gets compacted about once a week. The database has been behaving strangely the last couple of days. It wasn't designed very well (I am an heir, not the creator). Right now it's 413MB, and once I compact it, it should shrink to about 150MB.

    I know the database is nearing its limit. The Access db was a "temporary" system solution that's been in operation for 18 mos, and will probably need to keep going at least another six months.
    Last edited by LisaChow; 12-29-04 at 14:52.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •