Results 1 to 3 of 3
  1. #1
    Join Date
    Jan 2005
    Posts
    40

    Unanswered: catalog remote database

    Hi all,

    My DB2 8.1 with fix pack 4 on sun solaris.I have cataloged the remote node and the database on my local box and when iam trying to connect to that database its giving the following error, can anyone help in this matter will be appreciated..

    SQL30081N A communication error has been detected. Communication protocol
    being used: "TCP/IP". Communication API being used: "SOCKETS". Location
    where the error was detected: "". Communication function detecting the error:
    "connect". Protocol specific error code(s): "146", "*", "*". SQLSTATE=08001

    Thanks in advance

  2. #2
    Join Date
    Mar 2004
    Posts
    448
    1.use telnet <host IP/address> <port no at the db2 host>
    to check whether the host is listening on that port.

    2. Check the listener at the host

    db2set -all
    Look for the db2comm variable

    If not set it , using

    db2set db2comm=tcpip

    restart the instance.

    Check the listener using
    db2_ps command for db2tcpcm

    Set the port/name in svcname paramter of the instance

    db2 update dbm cfg using SVCNAME <portname>

    Set the portname in /etc/services file

    portname tcp/50000 // example

    regards

    Mujeeb

  3. #3
    Join Date
    Jan 2005
    Posts
    40
    Quote Originally Posted by bmujeeb
    1.use telnet <host IP/address> <port no at the db2 host>
    to check whether the host is listening on that port.

    2. Check the listener at the host

    db2set -all
    Look for the db2comm variable

    If not set it , using

    db2set db2comm=tcpip

    restart the instance.

    Check the listener using
    db2_ps command for db2tcpcm

    Set the port/name in svcname paramter of the instance

    db2 update dbm cfg using SVCNAME <portname>

    Set the portname in /etc/services file

    portname tcp/50000 // example

    regards

    Mujeeb
    db2comm variable was not set properly...its working fine after setting it to tcpip...

    Thanks mujeeb..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •