Results 1 to 4 of 4
  1. #1
    Join Date
    Aug 2004
    Posts
    7

    Unanswered: Search Key Not found in any record

    hi,
    I am trying to import a dbase table into A MICROSOFT ACCESS 2002.
    But it is giving me the error "Search Key not found in any record" while importing a table.
    Please lemme know if any bdy knows some thing about it.

  2. #2
    Join Date
    Dec 2002
    Location
    Préverenges, Switzerland
    Posts
    3,740
    i can commiserate.

    i have a "codebank" .mdb where i store interesting access ideas that i find on this and other sites. it's a simple application with some keywords and a memofield to copy/paste in the code example. there are already several hundred code examples in the db so this is very far from being a new system.

    yesterday i added a new record completely as usual... and got the same error that you have.

    i have not seen this error before in this or any other access application.
    the error is only with this one new record; my keyword search finds the bad record and i can pull it into the editor but i can't save edits to it or delete it (form level, query level, or table level).

    i haven't understood the problem yet: there are no missing keys and there is really nothing else obviously wrong. The only "special" thing about this troublesome record is that the memofield holding the code snippet is significantly bigger than all other entries in the db. i suspect there is an internal problem with the memo somewhere.

    as for a fix, i intend to try the following when i have a few minutes:

    plan-A: import all objects into a new empty db.

    if that doesn't work, plan-B: insert all except the misbehaving record into new tables and rebuild from there.

    if still no joy, plan-C: take all the data out to text and re-import it in a clean db.

    best of luck!

    izy
    currently using SS 2008R2

  3. #3
    Join Date
    Dec 2002
    Location
    Préverenges, Switzerland
    Posts
    3,740
    well, none of those worked! they were all blocked by a spurious error:
    "jet stopped the process - another user editing the same data"

    however, i finally got a compact&repair to run and everything seems to be ok now. c&r reported:
    currently using SS 2008R2

  4. #4
    Join Date
    Aug 2004
    Posts
    7

    Search key not found

    Well problem with my case is I am dealing with dbase tables and have to import data into access tables.
    One thing that is working is linking but when i apply joins or some query same problem pops up.
    So now thinking of importing data myself i.e writing a routine to import data into access tables.
    One more thing SQL Server imported the tables without any error.
    So it is for sure that this is a bug in ACCESS that microsoft shld fix.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •