Does Oracle allow their Standard Edition One database engine to be used in conjunction with their Java Edition of the Internet Application Server?

And if so, does it matter if their 9i versions are used or must it be 10g?

Thank you.