Results 1 to 5 of 5
  1. #1
    Join Date
    Jul 2004
    Posts
    38

    Unhappy Unanswered: Access 2003 Form problems

    I've created an .mdb file with many forms, with certain amount of controls in each form (with some coding). The file run normally in Access 2002 version but when it run on Access 2003 version, error occur as follows:

    A problem occurred while Microsoft Access was communicating with server OLE or ActiveX control.


    The above error message occurred whenever I try to press a control. Is there anything I need to set in Access 2003?? Pls help

  2. #2
    Join Date
    Jul 2003
    Location
    Michigan
    Posts
    1,941
    It's possible that when you installed Access 2003, your references all reset to the defaults. Check to see if both "OLE Automation" and "Microsoft ActiveX Data Objects 2.x Library" are turned on in your reference manager.
    Inspiration Through Fermentation

  3. #3
    Join Date
    Jul 2004
    Posts
    38
    Quote Originally Posted by RedNeckGeek
    It's possible that when you installed Access 2003, your references all reset to the defaults. Check to see if both "OLE Automation" and "Microsoft ActiveX Data Objects 2.x Library" are turned on in your reference manager.
    Thanks to your reply first.
    Yes, I've already checked in the reference setting and all the required reference library have been included.

    Anyone other idea??

  4. #4
    Join Date
    Jul 2003
    Location
    Michigan
    Posts
    1,941
    I found this on someones blog...

    [/quote]
    Here's a hint: Don't disable the "DCOM Server Process Launcher" service on XP SP2. It may look like one heck of a vulnerability when you really don't use DCOM at all, but, unfortunately, Microsoft Access 2003 does. It will simply open an instant message box stating "A problem occurred while Microsoft Access was communicating with the OLE server or ActiveX Control." if the service is not running.
    [quote]

    I'm not sure where that setting is at, though.
    Inspiration Through Fermentation

  5. #5
    Join Date
    Jul 2004
    Posts
    38
    Quote Originally Posted by RedNeckGeek
    I found this on someones blog...
    Here's a hint: Don't disable the "DCOM Server Process Launcher" service on XP SP2. It may look like one heck of a vulnerability when you really don't use DCOM at all, but, unfortunately, Microsoft Access 2003 does. It will simply open an instant message box stating "A problem occurred while Microsoft Access was communicating with the OLE server or ActiveX Control." if the service is not running.

    I'm not sure where that setting is at, though.
    you mean windows XP SP2 or Office XP SP2?? I've not installed the win xp sp2, so how to enable DCOM Server process Launcher?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •