Results 1 to 3 of 3
  1. #1
    Join Date
    Jan 2005
    Posts
    2

    Unanswered: Problems inserting chinese Characters into Oracle

    I have problems in inserting Chinese Characters into an Oracle Database. We are using an ODBC-Connection to the databases. We have 2 Systems for testing: An Oracle 8.1.7 and 9.2.

    The Oracle Parameter in the table NLS_DATABASE_PARAMETERS called NLS_CHARACTERSET is set to UTF-8.

    I am able to select previously imported chinese characters using a select statement. After the select, I cannot insert the Message into the Database, because I have question marks in my database. The same thing using a lokal MS Access Database works!

    When I send a nested SQL-Query like INSERT INTO... VALUES (SELECT my_chinese_chars FROM ...)) to Oracle, everything works fine.
    But I need at first the select to manage the Chinese-String and insert it back later in my Programm.

    I don´t know why I can select the chinese Chars, but cannot insert them again!?

  2. #2
    Join Date
    Jun 2004
    Location
    Liverpool, NY USA
    Posts
    2,509
    What is the charset on your client that is doing the select. It has to be compatable with or actually set to UTF-8. The question mark is the replacement character for unconvertable characters.
    Bill
    You do not need a parachute to skydive. You only need a parachute to skydive twice.

  3. #3
    Join Date
    Jan 2005
    Posts
    2
    I tried different character sets, setting the environment parameter called NLS_LANG, e.g. AMERICAN_AMERICA.UTF8 and CHINESE_CHINA.UTF8. I also tried CHINESE_CHINA.ZHS16GBK and CHINESE_CHINA.ZHS16CGB231280
    I know, my default value was wrong and was set to the western european codepage. I also installed the support of east-asian fonts on my (lcient)windows-system.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •