Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2005

    Unanswered: db2adutl grant access to a user


    I am running DB2 UDB v8.1.1.48 with TSM

    I would like to use db2adutl to grant access to a user that is not a db2 instance owner.

    I have been able to successfully do this with a different db2 instance user (db2inst2) but not with my own userid.

    I have done the following:
    1. As db2inst1: db2adutl grant user melissa on nodename abc for db sample password temp
    2. db2adutl queryaccess for all
    3. The permissions are there.
    4. As user melissa I set my environment.
    5. I change DSMI_CONFIG=/usr/tivoli/tsm/client/api/bin64/dsm.opt.backup
    6. In the dsm.sys file the stanza has the correct nodename and passwordaccess is equal to generate.
    7. As user melissa I run: db2adutl query db sample nodename abc owner db2inst1 password temp
    8. I get the error: Initialize session failed with ADSM return code 168.

    When I run this as db2inst2 I need to become root and run the dsmapipw command for everything to work. Do I need to run this command somewhere even though user melissa is not an instance owner?

    Thanks for your help; I hope this is not too confusing.


  2. #2
    Join Date
    Jan 2005
    Just thought I would let you know that I got it working. In case anyone was interested, maybe this will help someone else out.

    Step 1-3 does not have to be done.
    Step 4-5 is correct
    Step 6---this is where I was wrong...need to have PASSWORDACCESS PROMPT
    Step 7 should now work.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts