Results 1 to 5 of 5
  1. #1
    Join Date
    Jan 2005
    Posts
    4

    Unanswered: sql server access denied by non trusted connection

    hi at all, i know that in here there was a lot of thread over this argument, but none can helps me.
    I'm newbie on sqlserver. I'm first installed an instance of SQL Server 2000 with enterprise manager.
    As previous topics i cannot log into server because 'sa' user is not associated with a trusted connection. In installation time i selelected "windows only" authentication (because in mixed mode at end of installation i caught an error and installation was canceled). Now i **must** to connect with "sa" user, because i must to connect on sql server via jdbc driver from a java application. So i really cannot use windows authentication, but i must use sql authentication.
    Someone, ***please*** (i'm really deprived of hope, i spent 1 entire day to install correctly server and client components!!!!), can guide me to configure my installed sql server instance to accept connections with sql authentication?
    My sql server version is 8.00.194.

    thank you at all!

  2. #2
    Join Date
    Dec 2002
    Location
    Antwerp, Belgium
    Posts
    227
    Go to the enterprise manager, select your server and right-click on it. Choose "properties" from the menu and select tab "security". There you switch from "windows" mode to "mixed" mode.
    Johan

  3. #3
    Join Date
    Jan 2005
    Posts
    4
    thank you jora, i did it many times, (while waiting an angel response ), but this never affects that property. Every time i see server properties the authentication come back to "windows only". After many many many tries i've checked "autostart MSDTC" flag...and, finally, it works fine!
    thank you for your time. Problem solved.

  4. #4
    Join Date
    Nov 2004
    Location
    Dundee, Scotland
    Posts
    45
    I was having pretty much the same problems:

    http://www.dbforums.com/t1093573.html

    ...but I also fixed it by switching to mixed mode security. I find it helps if you copy and paste the exact error message into google
    Sunday Ironfoot

    SQL Server 2000 n00b

  5. #5
    Join Date
    Dec 2002
    Location
    Antwerp, Belgium
    Posts
    227
    what I forgot to mention was that you have to restart the SQL Server service to apply the change. Then it should work.
    Johan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •