Results 1 to 3 of 3
  1. #1
    Join Date
    Jan 2005
    Posts
    2

    Angry Unanswered: ODBC Connectivity Issues

    I have a windows 98 pc trying to connect to a sql server running on Windows Server 2003 via a frame relay. The 98 pc will connect to the domain and it is able to ping the server. However, when I try to use my MS Access program that connects to the sql server, I get this error message:

    Connection Failed
    SqlState: '01000'
    Sql ServerError: 11001
    [Microsoft][ODBC Sql Server Driver][TCP/IP Sockets] Connection Open (Connect ()).
    Connection Failed
    SqlState: '08001'
    Sql ServerError: 6
    [Microsoft][ODBC Sql Server Driver][TCP/IP Sockets] Specified Sql server not found.

    I have other pcs that connect to the Sql Server fine but they are located locally in the same building as the server. I've tried connecting through named pipes but for some reason, I get the same error. I have downloaded and installed the new MDAC drivers for the 98 pc. Any suggestions?

  2. #2
    Join Date
    Dec 2004
    Location
    Madison, WI
    Posts
    3,926

    ODBC Connection

    Just a couple of things to check:

    1. Are all the DSN names the same on all machines (are you using linked tables into MSAccess?) Does a DSN name exist on the PC?
    2. If they are linked tables into MSAccess, when you linked the table in MSAccess, did you check the "Save Password".
    3. Does the user have permissions to the tables in SQL Server? Is their loginID or their domain group set up for permissions to the database?

    Hope any of these helps.
    Last edited by pkstormy; 01-30-05 at 00:48.

  3. #3
    Join Date
    Jan 2005
    Posts
    2
    Yes, the DSN names are the same, and the user name and password are the same. There are multiple users that use the "generic" username and password and it works fine for them. I looked into the linked tables idea and this is what happened. When I link the tables in Access, it worked. However, when I exited the program and went back into it, it did not work anymore. Now when I try to link the tables again, it will not let me and the program will not work and I get that error message again. Any other ideas?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •