Results 1 to 7 of 7

Thread: Performance

  1. #1
    Join Date
    Sep 2003
    Posts
    218

    Unanswered: Performance

    I am running DB2 v8.1.6a on win2k platform...

    The issue that we are confronted with is that the same set of queries (part of two different product releases eg: R1.0 and R1.1) run against same database with all db/dbm and other related settings remaining constant yielding us different timing. While we expect the timing to be same if not better.. difference in timing is really worrying and customer wants to know the reason why this is happening...

    Some thing that i have checked..

    * DB settings
    * Explain plan statements
    * SQL statements + optimization
    * Data sets
    * Hardware, load on the system, no. of users etc

    Any ideas greatly appreciated.

    Thanks.

  2. #2
    Join Date
    Aug 2004
    Posts
    138
    did you see same access paths for both sets of queries in the explain plan? there is a chance query getting modified with new release

  3. #3
    Join Date
    Sep 2003
    Posts
    218
    yes i did - but no difference there, i mean access plan looks good.

  4. #4
    Join Date
    Jan 2005
    Posts
    191
    Try running an event monitor trace and compare the results.

    James Campbell

  5. #5
    Join Date
    Aug 2004
    Location
    London, UK
    Posts
    31

    Registry settings

    i.e. type "db2set -g"

    In the explain plan, check if the estimated cost is the same
    jdey@macehill.co.uk
    http://www.macehill.co.uk

  6. #6
    Join Date
    Aug 2004
    Posts
    138
    need more info on this..can you post both accessplans here?

  7. #7
    Join Date
    Sep 2003
    Posts
    218
    thanks for your response... I am reading explain plan output and trying to compare it with both versions... shall keep you posted on how it goes.

    thanks once again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •