Results 1 to 2 of 2
  1. #1
    Join Date
    Feb 2005
    Posts
    3

    Unanswered: [DBNETLIB][ConnectionRead (WrapperRead()).]

    Greetings,

    I have a problem I just cannot seem to find a solution to.

    I have an ASP 3.0 page that writes to a SQL db. One of the fields is a Text data type. My code works fine until I hit roughly 2100 characters. After that, every time I try to update the record (be it to write into the Text field or another regular field) I receive this error:

    Microsoft OLE DB Provider for SQL Server error '80004005'

    [DBNETLIB][ConnectionRead (WrapperRead()).]General network error. Check your network documentation.


    I noticed that this question was asked before by AMills in 9/04, but I did not quite understand the answer. This seems to be a fairly common problem but everything I have found refers to ASP.Net not ASP 3.0. I have tried to adjust the pooling and ConnectionTimeout but neither have helped.

    Has anyone else had this problem and can you shed some light on how I can solve it? I really need the help.

    Thanks,
    Brian

  2. #2
    Join Date
    Feb 2005
    Posts
    3

    Fixed

    It seems the problem relates to only being able to open instance of a table at a time.

    What I had done is create a rsListPatients that pulled information from joining 5 tables together. This allowed me to at any time look through this record source to extract information that I wanted.

    Since this record source was a grouping of multiple tables, I had then created 5 seperate record sources such as rsGeneral, rsLocation, rsFunding, etc. These are the record sources I used to write into the table with.

    I could do this effictively until I hit about 2100 characters in my Text data type field I was using as a log. I do not understand why it worked prior to that but not after.

    The fix however was to create a set of arrays to hold patient information from the rsListPatients. After the arrays were populated, I closed the rsListPatients record source. This in effect closed the the connection to the 5 tables, thereby allowing me to go into my table with the Text field and add more than 2100 characters. So far, this has seemed to be a fix. I am now up to over 4000 characters and will expand to more ppl trying to crash it soon.

    Anyway, anyone else who has this problem may benefit from this. It has taken me over a day and a half to figure it out. I was at the end of my ropes with this one!

    Sort

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •