Hi,

i'm facing some typical problem with CR10. its a serious issue in my application.

i deployed my crystalreport web-application(reports) application in expanded
format and it works. but if same application is made it as .war file
and deployed then i see an error as below,
error:
----------------------------------------------------------------------------
---------------------------------------
com.crystaldecisions.sdk.occa.report.lib.ReportSDK Exception: Error
loading
C:/bea/user_projects/domains/tatis_domain/myserver/.wlnotdelete/extract/myse
rver_TATIS_reports/reports.war!/RAMSystemPerformanceSummaryReport.rpt
---- Error code:-2147215356 Error code name:fileNotOpened
at
com.crystaldecisions.sdk.occa.report.lib.ReportSDK Exception.throwReportSDKEx
ception(Unknown
Source)
at
com.crystaldecisions.reports.reportengineinterface .JPEReportSource.<init>(Un
known
Source)
at
com.crystaldecisions.reports.reportengineinterface .JPEReportSource.a(Unknown
Source)
at
com.crystaldecisions.reports.reportengineinterface .JPEReportSourceFactory.cr
eateReportSource(Unknown
Source)
at jsp_servlet.__reports._jspService(__reports.java:2 43)
at weblogic.servlet.jsp.JspBase.service(JspBase.java: 33)
at
weblogic.servlet.internal.ServletStubImpl$ServletI nvocationAction.run(Servle
tStubImpl.java:1006)
at
weblogic.servlet.internal.ServletStubImpl.invokeSe rvlet(ServletStubImpl.java
:419)
at
weblogic.servlet.internal.ServletStubImpl.invokeSe rvlet(ServletStubImpl.java
:463)
at
weblogic.servlet.internal.ServletStubImpl.invokeSe rvlet(ServletStubImpl.java
:315)
at
weblogic.servlet.internal.WebAppServletContext$Ser vletInvocationAction.run(W
ebAppServletContext.java:6718)
at
weblogic.security.acl.internal.AuthenticatedSubjec t.doAs(AuthenticatedSubjec
t.java:321)
at
weblogic.security.service.SecurityManager.runAs(Se curityManager.java:121)
at
weblogic.servlet.internal.WebAppServletContext.inv okeServlet(WebAppServletCo
ntext.java:3764)
at
weblogic.servlet.internal.ServletRequestImpl.execu te(ServletRequestImpl.java
:2644)
at weblogic.kernel.ExecuteThread.execute(ExecuteThrea d.java:219)
at weblogic.kernel.ExecuteThread.run(ExecuteThread.ja va:178)

----------------------------------------------------------------------------
--------------------------------------

my application layout is as below

reports
|
+crystalreportview10(folder) - cystal report related files.
|
+image(folder)
|
+web-inf
| +classes - CrystalReportEngine-config.xml
| .
| .
+sample.jsp
+samle.rpt.
|

rpt file and jsp file resides in the same location and its
reportlocation is given as
<reportlocation>../..</reportlocation> in the crystalreportengine-config.xml
file.

IMP NOTE: error raises only if deployed as .war.

i'm using crystalreport10, weblogic 8.1 sp4.

Any help appreciated, its a very urgent issue to be resolved.

Thanks in Advance,

-Shariff.