Results 1 to 4 of 4
  1. #1
    Join Date
    Dec 2002
    Location
    Brazil
    Posts
    59

    Unanswered: Quick question about Universal Installer

    Hi everybody,

    I have a Sun Solaris Server with Oracle 9i Database and Oracle 9i Application Server installed.
    I am running Oracle Universal Installer from my machine to detect wich products from Database family I have installed in this server.
    But when I run the Universal Installer I see only the Oracle Home belonging to OAS instalation.
    I don't know what to do to see the oracle home database from the installer...
    My intention is to run Oracle Universal Installer to add a database product called PRO * C.
    Some help will be very welcome.
    PS: I am executing the ./runInstaller command from Oracle home database, but it opens the Oracle home OAS and its list of products.....

    Thank you all,
    Nadia

  2. #2
    Join Date
    May 2004
    Location
    Germany
    Posts
    25
    Hi,

    it does not depend on the location from which you start the installer. It depends on the contents of the file oraInst.loc which is located in /var/opt/oracle on a solris box.

    Check this file, it should contain something like this:
    inventory_loc=/opt/oracle/oraInventory
    inst_group=oinstall

    Make a backup of this file and edit the path to the inventory within your database Oracle home.
    Also set the ORACLE_BASE and ORACLE_HOME environment variable to your database Oracle home.

    Regards,
    Klaus

  3. #3
    Join Date
    Dec 2002
    Location
    Brazil
    Posts
    59
    Ok, I did what you suggested but When I inserted the new path that is the same of my database Oracle Home inside oraInst.loc, after running Oracle Universal Installer, I don't see any Oracle Homes anymore.
    So, now the OAS Oracle Home disappeared... and no list is available.
    I am sure Oracle_base and Oracle_home variables are corrects.

    My Database Oracle home is /u01/app/oracle/product/920.
    My OAS Oracle home is /u01/app/oracle/product/AS904.

    My oraInst.loc is like this:

    inventory_loc=/u01/app/oracle/product/920
    inst_group=oinstall

    Any idea?
    Nadia

  4. #4
    Join Date
    May 2004
    Location
    Germany
    Posts
    25
    OK,

    your old setting in oraInst.loc seems to be correct.
    The entry in oraInst.loc should point to the inventory folder which is normaly located at ORACLE_BASE/oraInventory, not to the ORACLE_HOME as it does now.
    Restore your old setting. I guess it was /u01/app/oracle/oraInventory.
    Your ORACLE_BASE seems to be /u01/app/oracle and you have two Oracle homes at /u01/app/oracle/product/920 and /u01/app/oracle/product/AS904.
    This should be right. I have no more ideas at the moment.

    Just two questions:
    Can you select the database Oracle home in a drop down list in the OUI GUI?

    And
    Search for oraInventory at the operating system (find /u01/app/oracle -name "*oraInventory*").
    Maybe you find an alternative oraInventory folder which is different to your old entry in oraInst.loc. If you do try this one in the oraInst.loc file.

    Good luck,
    Klaus

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •