Results 1 to 3 of 3
  1. #1
    Join Date
    Feb 2004
    Posts
    492

    Unanswered: ConnectionRead (WrapperRead())

    When executing an sp from the Analyzer, I get the following:

    [Microsoft][ODBC SQL Server Driver][DBNETLIB]ConnectionRead (WrapperRead()).
    Server: Msg 11, Level 16, State 1, Line 0
    General network error. Check your network documentation.

    I don't get this with other procedures, nor do the eventlog from w2k or errorlog from SQLServer indicate something is wrong. The procedure that I call, calls another procedure which gives this error. When I call that procedure directly, I do not get this (or any other) error.

    Any idea?

  2. #2
    Join Date
    Feb 2004
    Posts
    492
    I think I've solved it by installing MDAC 2.8 and the patch that follows.

  3. #3
    Join Date
    Feb 2004
    Posts
    492
    Or so I thought...

    It's a little bit different from the orignal though:

    I have a tight loop in a procedure that works it way down a table, the loop is supposed to fill a temp-table with values. Eventually, based on that temp-table, the final table is filled.

    I used to get the error when opening the cursor, that is: when I ran the procedure. Opening the cursor directly from the analyzer or running the select-itself: no error.

    I've been fiddling about trying this and that, for some reason the error keeps popping-up. It has moved to someplace inside the loop, but I don't know what to look for next.

    Any thoughts would be greatly appreciated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •