Results 1 to 3 of 3
  1. #1
    Join Date
    Apr 2004
    Location
    Nashville
    Posts
    52

    Unhappy Unanswered: Combo Box will not work

    Hi everyone,
    I created a combo box using the wizard to find records by Last Name, First Name, Middle Initial. It worked fine for a while. Now it will not pull in the proper record.

    Examples:
    I have two names, Mike Travis and Adam Travis. When I click on Mike Travis I get the record for Adam Travis. It will not produce another record unless I search for someone of a completely different Last name. This seems to occur within groups of people with the same last name. Any suggestions?

    Thanks,
    Bugme

  2. #2
    Join Date
    Feb 2004
    Posts
    533
    Sounds like you are syncronizing records on the 'Last Name' Field. This isn't reliable for the obvious reason, and problem your having.

    In your names table you should have an Index or ID field that uses an Auto Number, or a unique Person ID. When you define your combo list based on a query, make this ID field the first column in your listbox. In your related form make sure you include the Person ID number Field and use that field to syncronize with your list box. That should take care of it.

    If you don't want to see the ID in your combo list, in properties on the Format Tab set columns to 2 (or more) fields from your query. Then in column widths on the format tab, set the width of your lists first column to [0]


    ~
    ~

    Bill

  3. #3
    Join Date
    Apr 2004
    Location
    Nashville
    Posts
    52
    Thanks Saybill,
    That worked perfect!! I also had to change my RegistrationID index to Yes(No Duplicates).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •