Results 1 to 8 of 8
  1. #1
    Join Date
    Sep 2004
    Posts
    112

    Question Unanswered: Access database doing strange stuff and behaing erratically

    HI,
    I have an access 2000 application which I am currently working on but the last few days it has started acting very strange. When I am trying to write any code ie me.form.visible=true etc etc it will not do the correct syntax and repeated tries it works, I am inputting it correctly. also when I run any of the forms the screen flickers and the egg timer is always on but I can continue normally!!. I have tried the file on variour PC's and the same happens. I have virus checked the file and no viruses found, I have compacted the database.

    Has anyone else come accross this problem or might know what the problem is?

    Many thanks.

  2. #2
    Join Date
    Jan 2004
    Location
    The Netherlands
    Posts
    421
    Try using me.visible = true

    ??

  3. #3
    Join Date
    Sep 2004
    Posts
    112
    No its not that!

  4. #4
    Join Date
    Sep 2003
    Location
    MI
    Posts
    3,713
    try decompiling and then compiling ...
    Back to Access ... ADO is not the way to go for speed ...

  5. #5
    Join Date
    Sep 2004
    Posts
    112
    I have never decompiled? how do you do that?

    Saltman.

  6. #6
    Join Date
    Feb 2004
    Location
    CT,USA
    Posts
    250
    I have had something unusual happen yesterday. I believe it was triggered by an explore folder on a slow server erroring out and ending by task manager. The unusual behavior was that the database couldn't evaluate variables. Even in a '97 format db while using Access 2003, so I knew no mods had taken place. A simple reboot fixed the behavior in '97 & '03.

  7. #7
    Join Date
    Feb 2004
    Location
    Chicago, IL
    Posts
    1,312
    You might try importing everything into a new, empty database. For me this has fixed so many odd behaviors in Access that it is the second or third thing I try. When you do this, don't forget any references or file specifications.

  8. #8
    Join Date
    Feb 2004
    Location
    Canada
    Posts
    133
    I've had trouble typing in code while a timer was running. I had a blinking textbox going and while that form was in form view, I would have trouble typing in code. Every time the timer event fired it would ignore a couple of key strokes.

    It sort of worked if I typed real slow but was fine if I just put the form into design view while I entered code. So the problem was with the timer. HTH.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •