Results 1 to 4 of 4
  1. #1
    Join Date
    Feb 2005
    Posts
    2

    Unanswered: Problem with Backup Server

    My problem:

    I have recently installed ASE 12.5 on winxp. When I try to make a dump or load with isql or DBArtisan i get this message:

    "Can't open a connection to site 'SYB_BACKUP'. See the error log file in the SQL Server boot directory."

    Both data and backup servers have been started via Services console. I´ve tried also starting them with RUN_<server_name>.BAT and RUN_<server_name>_BS.bat with the same results.

    In log of the data server i have this output:
    -----------------------------------------

    00:00000:00017:2005/02/21 11:00:41.93 kernel nl__connect: Could not connect to site 'INFO02_BS', socket 12.
    00:00000:00017:2005/02/21 11:00:42.13 kernel nl__connect: net_connect failed to connect to site 'INFO02_BS'.
    : El sistema no puede hallar el archivo especificado.

    .
    00:00000:00017:2005/02/21 11:00:42.18 server Failed to connect to remote server INFO02_BS nlwnsck ether 10.0.0.53 5002 for site SYB_BACKUP. Trying the next query entry of this server, if any.
    00:00000:00017:2005/02/21 11:00:42.22 server Error: 7235, Severity: 17, State: 0
    00:00000:00017:2005/02/21 11:00:42.27 server No other query entry found for the remote server INFO02_BS - site SYB_BACKUP. Aborting this site handler, as no remote server responded. Please make sure the remote server is accepting connections.

    The underlined line means "system could not find the specified file" in spanish.

    These are the contents of the backup server log:
    ----------------------------------------------

    Logging Backup Server messages in file 'C:\sybase\ASE-12_5\install\INFO02_BS.log'

    Feb 21 07:53:22 2005: Backup Server: 1.70.1.1: Configuring the maximum shared memory usage to 48 MB.
    Feb 21 07:53:22 2005: Backup Server: 1.69.1.2: Configuring the number of service threads to 48.
    Feb 21 07:53:22 2005: Backup Server: 1.70.1.3: Configuring the shared memory per stripe to 1048576 bytes.


    Looks a like a dump petition never had been done. However when I ping the backup server with DSedit, it connects succesfully.

    The port of the bs is 5002, but strangely it does not appear when i make a netstat -a:
    -----------------------------------------------------------------------
    Proto Direcci¢n local Direcci¢n remota Estado
    TCP info-02:epmap 0.0.0.0:0 LISTENING
    TCP info-02:microsoft-ds 0.0.0.0:0 LISTENING
    TCP info-02:1025 0.0.0.0:0 LISTENING
    TCP info-02:1032 0.0.0.0:0 LISTENING
    TCP info-02:3107 0.0.0.0:0 LISTENING
    TCP info-02:3236 0.0.0.0:0 LISTENING
    TCP info-02:3805 0.0.0.0:0 LISTENING
    TCP info-02:4958 0.0.0.0:0 LISTENING
    TCP info-02:4961 0.0.0.0:0 LISTENING
    TCP info-02:5000 0.0.0.0:0 LISTENING
    TCP info-02:netbios-ssn 0.0.0.0:0 LISTENING
    TCP info-02:1034 0.0.0.0:0 LISTENING
    TCP info-02:1034 10.0.0.5:netbios-ssn ESTABLISHED
    TCP info-02:3107 10.0.0.5:5000 ESTABLISHED
    TCP info-02:3236 10.0.0.5:5000 ESTABLISHED
    TCP info-02:3805 10.0.0.53:ttcp ESTABLISHED
    TCP info-02:3841 10.0.0.73op3 TIME_WAIT
    TCP info-02:3843 10.0.0.73op3 TIME_WAIT
    TCP info-02:4283 0.0.0.0:0 LISTENING
    TCP info-02:4283 10.0.0.6:netbios-ssn ESTABLISHED
    TCP info-02:4961 10.0.0.5:5000 ESTABLISHED
    TCP info-02:ttcp 0.0.0.0:0 LISTENING
    TCP info-02:ttcp 10.0.0.53:3805 ESTABLISHED
    TCP info-02:5002 0.0.0.0:0 LISTENING
    TCP info-02:5002 0.0.0.0:0 LISTENING
    TCP info-02:3005 0.0.0.0:0 LISTENING
    TCP info-02:3006 0.0.0.0:0 LISTENING
    TCP info-02:3007 0.0.0.0:0 LISTENING
    TCP info-02:3025 0.0.0.0:0 LISTENING
    TCP info-02:3025 localhost:3840 TIME_WAIT
    TCP info-02:3025 localhost:3842 TIME_WAIT
    TCP info-02:4957 0.0.0.0:0 LISTENING
    TCP info-02:4957 localhost:4958 ESTABLISHED
    TCP info-02:4958 localhost:4957 ESTABLISHED
    UDP info-02:epmap *:*
    UDP info-02:microsoft-ds *:*
    UDP info-02:isakmp *:*
    UDP info-02:1028 *:*
    UDP info-02:ntp *:*
    UDP info-02:netbios-ns *:*
    UDP info-02:netbios-dgm *:*
    UDP info-02:1900 *:*
    UDP info-02:ntp *:*
    UDP info-02:1900 *:*
    UDP info-02:2234 *:*
    UDP info-02:4992 *:*

    A lot of thanks for any help and sorry for my horrid english.

  2. #2
    Join Date
    Dec 2004
    Posts
    25
    When you run sp_helpserver on the dataserver, can you see the backup server name ?

  3. #3
    Join Date
    Feb 2005
    Posts
    2
    Yep, these are the outputs:(I couldn't format them in a proper way)

    name network_name class status id cost
    INFO02_XP INFO02_XP ASEnterprise timeouts, no net password encryption, writable , rpc security model A 3 1000
    SYB_BACKUP INFO02_BS ASEnterprise timeouts, no net password encryption, writable , rpc security model A 4 1000
    SYB_EJB EJBServer ASEJB external engine auto start 2 [NULL]


    INFO02_BS is the backup_server

    I've tried this also wih no results:

    sp_dropserver SYB_BACKUP
    go

    sp_addserver SYB_BACKUP, null, INFO02_BS
    go

  4. #4
    Join Date
    Dec 2003
    Posts
    23
    I had a similar problem last week, except I'm running sybase on UNIX/Solaris. The backup server hung so I had to kill it. Problem is it didn't release the port, so I couldn't restart it. I rebooted the machine and was able to restart the backup server.

    Did you have to hard shutdown the backup server for any reason? Have you tried a reboot?

    Just an idea. This may not be your issue.

    -Tony

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •