Results 1 to 6 of 6
  1. #1
    Join Date
    Feb 2005

    Unanswered: problem to connect to db in local

    Hello all,

    I'am getting trouble connecting in local on a AIX machine to a db2 v8 database.
    when i am doing the query
    db2 connect to DBNAME user username using userpwd

    I'am getting this error:
    SQL30081N A communication error has been detected. Communication protocol
    being used: "TCP/IP". Communication API being used: "SOCKETS". Location
    where the error was detected: "". Communication function
    detecting the error: "recv". Protocol specific error code(s): "*", "*", "0".

    can anyone help me??

  2. #2
    Join Date
    Nov 2003
    this problem occoured on our servers multiple times.

    - a restart of the instance somtimes helps.
    - check the db2diag.log for startup errors.
    - did you catalog the database right?
    - did the connection work before?


  3. #3
    Join Date
    Jan 2003
    Is DB2 server up and running?
    Try using command:

    If database is up and running the error will appear, if not database will start. Execute above command and if error appears post error message.
    Last edited by grofaty; 02-25-05 at 03:39.

  4. #4
    Join Date
    Feb 2005
    yes the connection worked before i populate the db, the db2 is started, and maybe it can come from a catalog problem.

    I say it can come from a catalog problem because after having create the db, i try to catalog t with the command:
    db2 catalog database <databasename> at node <nomnoeud> authentication server

    and db2 said me that it is already catalogged(when db is create is it automatically catalogged???),i think this is strange so i run the uncatlog command : uncatalog db <databasename>, and rerun the catalog db command.

    to answer to grofaty, when i try db2start, i have only the error saying that db2 is already started.

  5. #5
    Join Date
    Feb 2005
    ok i have more precisions, when looking at db2diag.log, i get:

    ADM7009E An error was encountered in the "TCPIP" protocol support. A possible
    cause is that the maximum number of agents has been exceeded.

    2005-02-25- Instance:db2adm8 Node:000
    PID:2326586(db2tcpcm 0) TID:1 Appid:none
    common communication sqlcctcpconnmgr_child Probe:126

    Return code from sqleGetAgent =
    0x2FF1D394 : 0xFFFFFB36

    And that is true that when i stop and restart db2, i have anormally db2agent process launch. The strange things is that i can connect on some instance and not on other.
    Someone know why i get a lot of db2agent (idle) process like this just after start db2 (i have less than 400 and my MAXAGENTS is set to 400)

  6. #6
    Join Date
    Feb 2005
    another prercision; it is really strange that i get all this db2agent regarding my cfg:

    Priority of agents (AGENTPRI) = SYSTEM
    Max number of existing agents (MAXAGENTS) = 400
    Agent pool size (NUM_POOLAGENTS) = 200(calculated)
    Initial number of agents in pool (NUM_INITAGENTS) = 0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts