Results 1 to 7 of 7
  1. #1
    Join Date
    Feb 2005
    Posts
    1

    displaying LOB's in TOAD

    I currently use Oracle 10g and TOAD 7.4.0.3 and I am struggling with the display of LOB objects in TOAD. But it keeps showing this error message "A query with LOB's requires OCI8 mode, but OCI7 mode is used." I also tested the similar situation on PL/SQL Developer 6.0.4.906 with no problem. And of course, with MYSQL, displaying or manipulating LOB objects is just such an easy thing to do (for example, using PhpMyAdmin or DBACentral for mysql), in Oracle, however, you have to use Oracle DBMS_LOB packages to perform such tasks. Maybe do I need to configure Oracle in terms of OCI in order for TOAD to display LOB's properly?

  2. #2
    Join Date
    Apr 2007
    Posts
    2
    Quote Originally Posted by fixbo
    I currently use Oracle 10g and TOAD 7.4.0.3 and I am struggling with the display of LOB objects in TOAD. But it keeps showing this error message "A query with LOB's requires OCI8 mode, but OCI7 mode is used." I also tested the similar situation on PL/SQL Developer 6.0.4.906 with no problem. And of course, with MYSQL, displaying or manipulating LOB objects is just such an easy thing to do (for example, using PhpMyAdmin or DBACentral for mysql), in Oracle, however, you have to use Oracle DBMS_LOB packages to perform such tasks. Maybe do I need to configure Oracle in terms of OCI in order for TOAD to display LOB's properly?
    I've the same problem. A query with LOB's requires OCI8 mode, but OCI7 mode is used.
    How can I solve this problem?

  3. #3
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,622
    Those who live by the GUI, die by the GUI.
    When all else fails use SQL*Plus.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    There are no stupid questions, but there are a LOT of Inquisitive Idiots.

  4. #4
    Join Date
    Dec 2003
    Posts
    1,074
    TOAD v 8.6.0.38 has no problems selecting from a CLOB in a 10.1.0.3.0 db, for me. I'm not sure how TOAD relates to the OCI, though, so I can't guarantee it would work for you.

    Support at quest is pretty good, though, if you don't think you can upgrade: support@quest.com


    -=Chuck

  5. #5
    Join Date
    Dec 2003
    Location
    Oklahoma, USA
    Posts
    354
    Running TOAD 9.0.1.8 (latest as of 18 Apr, 07) and it will allow you to view the BLOB as character/text or "save to file and view" -- works nice.
    JoeB
    save disk space, use smaller fonts

  6. #6
    Join Date
    Apr 2007
    Posts
    2
    I installed toad 8.5 and I have no problem anymore.
    Thanks.

  7. #7
    Join Date
    Feb 2008
    Posts
    1

    LOB's requires OCI8 mode

    I use TOAD 7.3 on Oracle 10g and was having this problem, as well. The workaround I used is to wrap the LOB in DBMS_LOB.substr() within the select statement.
    For example:
    Select DBMS_LOB.substr(descrlong) from Table;

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •