Results 1 to 4 of 4

Thread: Export Problem

  1. #1
    Join Date
    Feb 2005
    Posts
    19

    Question Unanswered: Export Problem

    I am trying to export the full data base from Oracle 9i.. I am continously getting this error

    EXP-00008: ORACLE error 1406 encountered
    ORA-01406: fetched column value was truncated
    EXP-00000: Export terminated unsuccessfully

    I looked up the details for error ORA-01406. It says that this error is due to the size of Buffer. I changed the the buffer size to 2GB in bytes.. but it still give me the same error ... any suggestions

    Thanks

  2. #2
    Join Date
    Jul 2003
    Posts
    2,296
    you must have a LOB or CLOB larger than 2GB
    try increasing the buffer to accomodate those columns.
    - The_Duck
    you can lead someone to something but they will never learn anything ...

  3. #3
    Join Date
    Feb 2005
    Posts
    19

    Question

    I tried setting buffer to 3GB but i am still getting the same error. Is there is any other way I can solve this problem.


    any suggestions???

    Thanks

  4. #4
    Join Date
    Aug 2003
    Location
    West
    Posts
    101

    I read this .....

    When running Oracle9i release 1 (9.0.1.0.0):
    ============================================

    - patch-set 9.0.1.1.0 -
    download from MetaLink as Patch#: 1968474 -
    patch-set 9.0.1.2.0 -
    download from MetaLink as Patch#: 2072050

    These are
    complete Product Patches each about ~160 MB in size Explanation -----------
    You are using object type definitions in the Oracle8i / Oracle9i database.
    Because of [BUG:1874468] (not a public bug), the Export utility terminates
    the export when one of the lines of the object type definition, which was
    used to define the type initially, has a length similar to the maximum of
    VARCHAR2(4000). The patch corrects this problem and enables the export
    utility to export these specific object type definitions too.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •