Results 1 to 9 of 9
  1. #1
    Join Date
    Apr 2004
    Location
    Melbourne
    Posts
    144

    Unanswered: Single User Mode

    I'm trying to restore the master database. I can't seem to start the SQL Server in single user mode.

    Through the command prompt

    1. net stop MSSQL$AIMS
    2. C:\Program Files\MS SQL Server\MSSQL$AIMS\Binn\sqlservr.exe -c -m

    It runs saying that it's in single user mode etc etc.

    When i open enterprise manager and try to restore the database, it comes up in a prompt saying i need to put it in single user mode

  2. #2
    Join Date
    Oct 2003
    Location
    Jordan
    Posts
    28

    Smile

    Hi

    To rebuild the master database

    Shutdown MS-SQL and then run Rebuildm.exe. This is located in the Program Files\Microsoft SQL Server\80\Tools\Binn directory.
    Firas arramli
    Systems Analyst

  3. #3
    Join Date
    Sep 2004
    Location
    Birmingham, UK
    Posts
    18
    Whenever I have tried to restore the master database I have had to do it through Query Analyser logged in as sa. I'm not sure if by using Enterprise Manager you are taking it out of single user mode (as you are not logging in as sa)? I'm not sure on that ... but that's how I reasoned it to myself!

  4. #4
    Join Date
    Aug 2002
    Location
    Prague
    Posts
    77
    According to path to your binn directory, I assume it is a named instance, check out -s startup parameter. hope this helps. mojza

  5. #5
    Join Date
    Oct 2003
    Location
    Jordan
    Posts
    28

    Smile

    Hi

    After running SQL services in single users mode use OSQL.EXE to restore your database using ther RESTORE command.
    Firas arramli
    Systems Analyst

  6. #6
    Join Date
    Apr 2004
    Location
    Melbourne
    Posts
    144
    when i run the sqlservr.exe now, it says that it can't connect to the errorlog. Something is wrong

    the problem is i can't put it in single user mode. It's a SQL Server Developer Edition by the way.

  7. #7
    Join Date
    Aug 2002
    Location
    Prague
    Posts
    77
    This error message means that you're attempting to start server from the command line that is already running as Windows Service. Check all running sql services (default and named) on the computer. Did you take a look at -s startup option? mojza

  8. #8
    Join Date
    Apr 2004
    Location
    Melbourne
    Posts
    144
    I went to the command prompt
    C:\Program Files\Microsoft SQL Server\MSSQL\Binn\sqlservr.exe -c -m

    Left the Command prompt open.
    Restored using Enterprise Manager --> worked OK

    Now i tried it again on the named instance
    C:\Program Files\Microsoft SQL Server\MSSQL$TEST\Binn\sqlservr.exe -c -m

    This error has come up.
    17050: initerrlog: Could not open error log file 'd:\MYSQL\log\ERRORLOG'. Operating system error = 32(error not found).

    Is it because i have tried using the command before and i thought you didn't need to switch it to multi user mode. Or am i doing something wrong ??

  9. #9
    Join Date
    Aug 2002
    Location
    Prague
    Posts
    77
    just add -s startup option to start your named instance

    sqlservr.exe -c -m -sTEST

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •