Results 1 to 3 of 3

Thread: Create Table

  1. #1
    Join Date
    Feb 2005
    Posts
    118

    Unanswered: Create Table

    Hi All !

    Do I have to do something extra to use
    CREATE TABLE with the NOT LOGGED INITIALLY clause ?
    I ask this because I see the transaction log full messages in my log file.
    I did not expect to see the transaction log full message if I am doing multiple inserts in a single unit of work.
    Any thoughts as to what could be going wrong ?

    Anil

  2. #2
    Join Date
    May 2003
    Location
    USA
    Posts
    5,737
    Not sure what interface you are using, but you need to shut off auto-commit and only commit explicitly when all the inserts are done.

    If you are using the CLI, then the +c option shuts off auto-commit. See the Command Reference manual for details on CLI options. Don't forget to explicitly commit after you do all the inserts.
    M. A. Feldman
    IBM Certified DBA on DB2 for Linux, UNIX, and Windows
    IBM Certified DBA on DB2 for z/OS and OS/390

  3. #3
    Join Date
    Oct 2004
    Location
    DELHI INDIA
    Posts
    338
    Thatz correct Marcus.
    In our project we used to get similar problems while inserting (importing ) thousands of records together. We used very frequent commit statement after every 5000 rows and got the problem fixed.

    Increasing the "Logprimary" and "Logsecondary" configuration parameter will fix the problem? You can try this too.

    Thanks,
    Jayanta Datta
    Xansa India

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •