Results 1 to 7 of 7
  1. #1
    Join Date
    Mar 2005
    Posts
    3

    Oracle Error on oracle 10g fedora core 3

    install_driver(Oracle) failed: Can't load '/usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi/auto/DBD/Oracle/Oracle.so' for module DBD::Oracle: libclntsh.so.10.1: failed to map segment from shared object: Permission denied at /usr/lib/perl5/5.8.5/i386-linux-thread-multi/DynaLoader.pm line 230., referer: http://laila/tapes/send_container.shtml

  2. #2
    Join Date
    Feb 2005
    Location
    Leesburg, VA
    Posts
    42
    Try doing a locate or find to find the file "libclntsh.so.10.1" then chmod 777 it. If that doesn't work, try doing a chmod 777 on Oracle.so.

    Not sure which file it's actually finding fault with.
    Steven Karam
    Oracle 10g Certified Master
    Web: OrclDBA.com
    Email: steve@orcldba.com

  3. #3
    Join Date
    Jun 2004
    Location
    Liverpool, NY USA
    Posts
    2,434
    Quote Originally Posted by deolsabh
    install_driver(Oracle) failed: Can't load '/usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi/auto/DBD/Oracle/Oracle.so' for module DBD::Oracle: libclntsh.so.10.1: failed to map segment from shared object: Permission denied at /usr/lib/perl5/5.8.5/i386-linux-thread-multi/DynaLoader.pm line 230., referer: http://laila/tapes/send_container.shtml
    did you make sure to run root.sh as root after the install. A number of permissions have to be set that only root can do.
    Bill
    You do not need a parachute to skydive. You only need a parachute to skydive twice.

  4. #4
    Join Date
    Mar 2005
    Posts
    3
    Yes i did run root.sh after the install

  5. #5
    Join Date
    Mar 2005
    Posts
    3
    i changed the permission also but its still same

  6. #6
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,649
    Is PERL's DBD:BI installed on this system?
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    There are no stupid questions, but there are a LOT of Inquisitive Idiots.

  7. #7
    Join Date
    Mar 2005
    Posts
    1
    If you turn off selinux, you will not receive the error message.

    Does anyone know how to configure selinux to allow this?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •