Results 1 to 2 of 2
  1. #1
    Join Date
    Nov 2003
    Location
    Belgium
    Posts
    25

    Angry Unanswered: Memory grow failed for pool Fast Data Pipe

    Hi,

    We have a problem when we execute the following command on ASE version 12.5.3 ESD#1:

    1> sp_configure 'allow updates to system tables',1
    2> go
    Msg 10840, Level 16, State 8
    Server 'Oceanix', Procedure 'sp_configure', Line 708
    Memory grow failed for pool Fast Data Pipe. Error code 0. This is possibly due to memory fragmentation. This pool may grow on demand. Please increase 'max memory' and
    retry the configuration.
    Parameter Name Default Memory Used Config Value Run Value Unit Type
    ------------------------------ ----------- ----------- ------------ ----------- -------------------- ----------
    allow updates to system tables 0 0 1 1 switch dynamic
    Configuration option changed. The SQL Server need not be rebooted since the option is dynamic.
    Changing the value of 'allow updates to system tables' does not increase the amount of memory Adaptive Server uses.

    We see also in the error log this message : Internal error, FDP API, fdp_get_memory(): Failed to allocate 1041258 bytes.

    We have upgraded the NT server from 512 Mb to 2 gb and we have changed the configuration of max memory, but the error is still there.

    Any ideas of when is occured this error ?

    Thx in advance,

    Xavier
    Last edited by xavier_urbain; 09-22-05 at 08:18.

  2. #2
    Join Date
    Feb 2002
    Location
    Willy is on vacation
    Posts
    1,208
    this is definetly memory allocation related.

    If you have already bumped up the real memory on the box to 2GB, windows may also need something in the system folder that tells it how much to use.

    I'm not too familiar with windows memory management, but you may need to tweak something in the system icon on the control panel for memory related parameters.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •